Bug 207813 - IPv6 hogs down the system.
IPv6 hogs down the system.
Status: CLOSED DUPLICATE of bug 207137
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-23 15:16 EDT by Ivo Sarak
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 12:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2006-09-23 15:16:27 EDT
Description of problem:
After system update the system startup will halt for about 20 minutes because
the init IPv6 is segfaulting and consuming all of the system CPU time.

Version-Release number of selected component (if applicable):
initscripts-8.40-1

How reproducible:
Always.

Steps to Reproduce:
1. Install FC6test3;
2. Perform a system update with yum;
  
Actual results:
System will have a lot of difficulty to start up again. There is no lockup, but
it will take a lot of time the system will past the network startup.

Expected results:
No such issues.

Additional info:

If I do get the system up and issue "/etc/init.d/network restart" then I get this:
[root@lappar ~]# /etc/init.d/network restart
/etc/init.d/network: line 54:  2240 Segmentation fault     
/etc/sysconfig/network-scripts/init.ipv6-global stop pre
Shutting down loopback interface:  /etc/sysconfig/network-scripts/ifdown-eth:
line 67:  2364 Segmentation fault     
/etc/sysconfig/network-scripts/ifdown-ipv6 ${CONFIG}
                                                           [  OK  ]
/etc/init.d/network: line 54:  2432 Segmentation fault     
/etc/sysconfig/network-scripts/init.ipv6-global stop post
</etc/init.d/network: line 54:  2498 Segmentation fault     
/etc/sysconfig/network-scripts/init.ipv6-global start pre
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0... done.
                                                           [  OK  ]
/etc/init.d/network: line 54:  2771 Segmentation fault     
/etc/sysconfig/network-scripts/init.ipv6-global start post
[root@lappar ~]# 

The issue is not kernel related - tested with kernel-2.6.17-1.2630.fc6 and
kernel-2.6.17-1.2647.fc6

How to disable the IPv6 as I do not even need it?
Comment 1 Bill Nottingham 2006-09-25 12:47:09 EDT

*** This bug has been marked as a duplicate of 207137 ***

Note You need to log in before you can comment on or make changes to this bug.