Bug 207830 - TB31e7d981 system-install-packages:109:populatePackages:AttributeError: 'SinglePackageInstaller' object has no attribute 'read_ts'
Summary: TB31e7d981 system-install-packages:109:populatePackages:AttributeError: 'Sing...
Status: CLOSED DUPLICATE of bug 205890
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-24 06:39 UTC by Ismail Asci
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 13:34:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ismail Asci 2006-09-24 06:39:13 UTC
Description of problem:

When i run "system-install-packages bla.rpm" or click an rpm package getting
this error...

Component: Software Installer
Summary: TB31e7d981 system-install-packages:109:populatePackages:AttributeError:
'SinglePackageInstaller' object has no attribute 'read_ts'

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 244, in ?
    main()
  File "/usr/sbin/system-install-packages", line 240, in main
    pkginst.run()
  File "/usr/sbin/system-install-packages", line 230, in run
    self.doRefresh()
  File "/usr/sbin/system-install-packages", line 90, in doRefresh
    self.populatePackages()
  File "/usr/sbin/system-install-packages", line 109, in populatePackages
    po = YumLocalPackage(ts=self.read_ts, filename=pkg)
AttributeError: 'SinglePackageInstaller' object has no attribute 'read_ts'

Local variables in innermost frame:
installs: []
self: <__main__.SinglePackageInstaller object at 0xa12ec2c>
updates: []
pkg: Depo/skype-1.2.0.18-fc3.i586.rpm

Comment 1 Jeremy Katz 2006-09-25 13:34:08 UTC

*** This bug has been marked as a duplicate of 205890 ***


Note You need to log in before you can comment on or make changes to this bug.