Bug 2078663 - periodic-ci-openshift-release-master-nightly-4.9-e2e-metal-ipi-compact permfailing - networkpolicy tests
Summary: periodic-ci-openshift-release-master-nightly-4.9-e2e-metal-ipi-compact permfa...
Keywords:
Status: CLOSED DUPLICATE of bug 2077369
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-26 00:44 UTC by Ben Parees
Modified: 2022-04-26 00:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
job=periodic-ci-openshift-release-master-nightly-4.9-e2e-metal-ipi-compact=all job=periodic-ci-openshift-release-master-nightly-4.8-e2e-metal-ipi-compact=all
Last Closed: 2022-04-26 00:58:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ben Parees 2022-04-26 00:44:08 UTC
job:
periodic-ci-openshift-release-master-nightly-4.9-e2e-metal-ipi-compact 

is failing frequently in CI, see testgrid results:
https://testgrid.k8s.io/redhat-openshift-ocp-release-4.9-informing#periodic-ci-openshift-release-master-nightly-4.9-e2e-metal-ipi-compact

sample job:
https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/periodic-ci-openshift-release-master-nightly-4.9-e2e-metal-ipi-compact/1518379613510701056

all of these tests are failing consistently in this job:

client should enforce egress policy allowing traffic to a server in a different namespace based on PodSelector and NamespaceSelector [Feature:NetworkPolicy] [Skipped:Network/OpenShiftSDN/Multitenant] [Skipped:Network/OpenShiftSDN] 
[Suite:openshift/conformance/parallel] [Suite:k8s]

[sig-network] NetworkPolicyLegacy [LinuxOnly] NetworkPolicy between server and client should enforce multiple egress policies with egress allow-all policy taking precedence [Feature:NetworkPolicy] [Skipped:Network/OpenShiftSDN/Multitenant] [Skipped:Network/OpenShiftSDN] [Suite:openshift/conformance/parallel] [Suite:k8s]

[sig-network] NetworkPolicyLegacy [LinuxOnly] NetworkPolicy between server and client should enforce policies to check ingress and egress policies can be controlled independently based on PodSelector [Feature:NetworkPolicy] [Skipped:Network/OpenShiftSDN/Multitenant] [Skipped:Network/OpenShiftSDN] [Suite:openshift/conformance/parallel] [Suite:k8s]

[sig-network] NetworkPolicyLegacy [LinuxOnly] NetworkPolicy between server and client should ensure an IP overlapping both IPBlock.CIDR and IPBlock.Except is allowed [Feature:NetworkPolicy] [Skipped:Network/OpenShiftSDN/Multitenant] [Skipped:Network/OpenShiftSDN] [Suite:openshift/conformance/parallel] [Suite:k8s]

[sig-network] NetworkPolicyLegacy [LinuxOnly] NetworkPolicy between server and client should work with Ingress,Egress specified together [Feature:NetworkPolicy] [Skipped:Network/OpenShiftSDN/Multitenant] [Skipped:Network/OpenShiftSDN] [Suite:openshift/conformance/parallel] [Suite:k8s]


Note that these tests seem to imply they should be skipped on openshift SDN, yet they are not being skipped in this job run which, as it doesn't claim to be ovn, is, i assume, running on SDN.

So i'm not sure if that skip logic not being respected is part of the issue here.

Comment 2 Ben Parees 2022-04-26 00:58:12 UTC

*** This bug has been marked as a duplicate of bug 2077369 ***


Note You need to log in before you can comment on or make changes to this bug.