This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 208060 - nv: cursor missing after vt switch
nv: cursor missing after vt switch
Status: CLOSED DUPLICATE of bug 182517
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 02:17 EDT by Daniel Adad
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 17:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Adad 2006-09-26 02:17:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Description of problem:
After a clean install, I do a resolution change in display manager to get to the best resolution my graphics adapter and monitor support. After logging off and re-logging in, the mouse pointer is invisible, but the device is operative: you can trace its movement as objects get focus, and you can also click on icons/menus, but the pointer itself is gone invisible. Using Vesa driver, as nvidia do not display the right way.

The problem is solved adding:

Option "HWCursor" "off"

in the section Device in file /etc/X11/xorg.conf

This issue has been occurring since FC3, and is still present at FC6 Test 3.

The motherboard is an Asus A8N-VM CSM (chipset Geforce 6150, nForce 430), using onboard video (64MB), 1 GB DDR 400 (PC3200), Athlon 64 3500+, no overclocking.

Others have also reported this issue in Fedora Forums.

Version-Release number of selected component (if applicable):
fc3, fc4, fc5, fc6

How reproducible:
Always


Steps to Reproduce:
1. Fresh install
2. Change resolution to 1280*1024/16Million colors, vesa driver
3. Log off and re-log in as a normal user


Actual Results:
The mouse pointer has gone invisible

Expected Results:
The system should have entered into the right resolution and mouse pointer should be visible.

Additional info:
Comment 1 Dr. Adrian Wrigley 2006-11-04 07:51:45 EST
Also occurs on Gigabyte GA K8N51GMF hardware with similar onboard video,
using release version FC6.  Occurs with nv driver.  Happens always at any
resolution.

Can also be solved by adding:
Option      "SWCursor" "1"
to device section.
Comment 2 Matthew Miller 2007-04-06 12:19:10 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 3 Daniel Adad 2007-04-06 15:23:48 EDT
This issue is still present in FC6 Release Version, even with nvidia proprietary
drivers.
Comment 4 Matthew Miller 2007-04-06 15:25:36 EDT
Thanks.
Comment 5 Matěj Cepl 2007-04-11 11:06:04 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Matěj Cepl 2007-07-04 17:28:07 EDT
Sorry, the previous comment is nonsense -- this is a duplicate of well known bug.

*** This bug has been marked as a duplicate of 182517 ***

Note You need to log in before you can comment on or make changes to this bug.