Bug 208065 - FC5/6.3 install error with FreeBSD on same drive
FC5/6.3 install error with FreeBSD on same drive
Status: CLOSED DUPLICATE of bug 194264
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
Reported: 2006-09-26 03:35 EDT by ehanko
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-05 13:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Debug info from (71.73 KB, text/plain)
2006-09-26 03:35 EDT, ehanko
no flags Details

  None (edit)
Description ehanko 2006-09-26 03:35:22 EDT
Description of problem: The install process halts with the following error:
"Error informing the kernel about modifications to partition /dev/hda1 -- Device
or resource busy". This error seems to be independent of the partition chosen
for installation, I tested two different partitions. Both the ignore and cancel
buttons lead to a reboot with no changes made to the hard drive. 

Version-Release number of selected component (if applicable):

How reproducible: This appears to be caused by a FreeBSD install on /dev/hda1
(same drive). Before installing FreeBSD, FC5 was installed without any errors. 

Steps to Reproduce:
1. With a FreeBSD install on /dev/hda1, boot from any FC5/FC6.3 install DVD
2. After package selection and the descriptions where logs can be found after
installl, the above error is produced. 
Actual results: Error message and in most of the cases no changes to mbr and
partitioning scheme. In one attempt, a previous installation of grub was removed
and the partitioning scheme was altered. iirc, this was the attempt in which I
chose not to install grub. 

Expected results: Installation of the operating system

Additional info: This appears to be an older bug:
Comment 1 ehanko 2006-09-26 03:35:22 EDT
Created attachment 137110 [details]
Debug info from
Comment 2 Jeremy Katz 2006-10-05 12:45:16 EDT
I can't hit this here -- do you see it with the FC6 pre candidate?
Comment 3 ehanko 2006-10-05 13:16:08 EDT
Yes, I tried both FC6test3 and FC5. Exactly the same results. 
Comment 4 David Cantrell 2006-10-05 13:44:37 EDT

I say this is a dupe of bug #194264.  My investigation in to this problem a few
months back was parted related and, well, more important things came up.

*** This bug has been marked as a duplicate of 194264 ***

Note You need to log in before you can comment on or make changes to this bug.