Bug 208094 - Anaconda should verify install source before askmethod exists
Anaconda should verify install source before askmethod exists
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
: 209939 231885 428020 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 09:15 EDT by Gilboa Davara
Modified: 2008-07-11 16:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-11 16:14:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2006-09-26 09:15:26 EDT
Description of problem:
When selecting HTTP/FTP install source, Anaconda asks for the URL and directory
of install source and proceeds with the installation.
If the installation source fails (due to missing/invalid/etc repo-data), the
installation aborts without giving the user an option to adjust his install
source selection.

Version-Release number of selected component (if applicable):
Rawhide 26092006

How reproducible:
Always

Steps to Reproduce:
1. Download the Rawhide rescue ISO.
2. Select HTTP install.
3. Input a valid URL that does not contain the required repo-data.
  
Actual results:
Anaconda will proceed to select the installation target, partition the drives,
etc, but once it begins the actual installation, it'll fail on invalid repo-data
and abort the installation.

Expected results:
Anaconda should:
A. (re)Verify the install source -before- switching to the actual X-based
installation.
B. (re)Prompt the user for a valid installation source URL if the URL is
invalid/unavailable.

Additional info:
Comment 1 Jeremy Katz 2006-09-27 14:46:06 EDT
Unfortunately, with the way things are currently laid out and starting to make
things more generic for differing backends, we really can't do this right now.  

I've got some thoughts on how to make this better, but they're not FC6 material
Comment 2 Gilboa Davara 2006-09-27 16:10:10 EDT
OK Thanks.
I assume you'll keep this open and pick it up when FC7 starts rolling?

- Gilboa
Comment 3 Tim Jackson 2006-12-17 05:23:21 EST
An additional example of this same problem is that if you are using a valid
install disk (e.g. CD, DVD) then if the alternative method selected via
askmethod fails, anaconda goes right ahead and starts using the local install
media *without any warning or prompt* (except if you go to the console and look
in anaconda.log). 

This can potentially lead to a broken installation if, for example, you have CD1
of a set but not the rest of the CDs...anaconda starts installing off the CD
when it should have been using HTTP, gets to where it needs CD2...CD2 doesn't
exist, so you have a borked install.
Comment 4 Chris Lumens 2007-03-15 13:26:49 EDT
*** Bug 231885 has been marked as a duplicate of this bug. ***
Comment 5 David Cantrell 2007-03-15 17:33:54 EDT
*** Bug 209939 has been marked as a duplicate of this bug. ***
Comment 7 Johan Kok 2008-01-13 15:01:32 EST
*** Bug 428020 has been marked as a duplicate of this bug. ***
Comment 8 Gilboa Davara 2008-03-06 07:41:47 EST
Fix in time for F9?
Comment 9 Bug Zapper 2008-05-13 22:22:52 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Andy Lindeberg 2008-06-02 16:01:01 EDT
Is this still a problem in F9?
Comment 11 Gilboa Davara 2008-07-08 09:11:57 EDT
I'll test it ASAP.
Comment 12 Chris Lumens 2008-07-11 16:14:54 EDT
Probably still a problem in F9, but definitely fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.