Bug 208167 - cannot close window when tcsh is running a command
cannot close window when tcsh is running a command
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcsh (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 14:23 EDT by jas
Modified: 2010-03-23 07:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 07:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
running xterm with tcsh, ssh to the same host, start up xterm, and try to close the original xterm - fails (26.18 KB, application/x-bzip2)
2006-10-06 12:00 EDT, jas
no flags Details
second try (53.11 KB, application/x-bzip2)
2006-10-06 14:24 EDT, jas
no flags Details

  None (edit)
Description jas 2006-09-26 14:23:02 EDT
Description of problem:

My shell is tcsh.  If I start up an xterm, and hit the close button in my Window
manager, the window closes.  On the other hand, if I do something in that window
(eg. hup sleep 10000), and then try to close the xterm window, the window does
not close until the sleep is complete.    I don't know if the problem is tcsh, or
xterm.  It may even be a kernel issue.
Comment 1 Miloslav Trmač 2006-10-05 13:36:20 EDT
Can you create a temporary directory, run (strace -ff -o log xterm) in it,
reproduce the behavior, and attach an archive containing the contents of the
directory, please?

E.g.:
$ mkdir t
$ cd t
$ strace -ff -o log xterm
[now reproduce the behavior in the newly opened xterm]
$ cd ..
$ tar cjf xterm-strace.tar.bz2 t
$ rm -r t
... and attach the created xterm-strace.tar.bz2.
Comment 2 jas 2006-10-06 12:00:59 EDT
Created attachment 137931 [details]
running xterm with tcsh, ssh to the same host, start up xterm, and try to close the original xterm - fails
Comment 3 Miloslav Trmač 2006-10-06 14:14:33 EDT
Thanks.  Is that the trace of the "inner" or the "original" xterm?  The trace
doesn't contain any indication of running ssh.  A trace of the xterm you attempt
to close is necessary to find out whether the bug is in tcsh or xterm.
Comment 5 jas 2006-10-06 14:24:05 EDT
Created attachment 137937 [details]
second try
Comment 6 Miloslav Trmač 2006-10-09 11:14:33 EDT
Can you precisely, one step at a time, describe the way to reproduce the problem,
please?

The second trace shows running tcsh[1] in xterm[1], with unsuccessful attempts
to log in via ssh - but a trace of xterm[1] is missing.  It also shows running
tcsh[2] in xterm[2], running "sleep 1000".  xterm[2] is terminated using Ctrl+C.
What is the relation of the two xterms?  Which one have you tried to close?
If both, in what order?
Comment 7 jas 2006-10-10 10:56:36 EDT
Simple.
I run xdm.
When I login through xdm, an xterm window pops up, and then the window manager
begins.  I run tcsh for my login so tcsh is running in the xterm.
If I try to close the original xterm window, it will close.
If instead, I type "sleep 1000" in the xterm window, and then try to close the
window by clicking on the "X" in the top right hand corner, the window will not
close.
The window will only close when the sleep is complete.

That's it.

Does it not work like that for you?
    
Comment 8 Miloslav Trmač 2006-11-10 12:31:48 EST
No, the window closes immediately (using xdm, twm and xterm).

I'm afraid your new problem description doesn't clarify the questions in comment #6.

A trace of _the specific_ xterm you attempt to close and _the specific_ tcsh
running in the xterm is necessary to find out whether the bug is in tcsh or
xterm.  If you can't remember the sequence of events from comment #5, please
attach a new strace that contains a strace of the specific xterm that you tried
to close and the specifix tcsh running in that xterm, along with any necessary
description of the steps to reproduce or any necessary relations between
different xterm or tcsh processes.

If you cannot reproduce the problem in a new xterm running within strace,
you can use the -p argument of strace to attach to a running xterm and a running
tcsh, although starting the xterm process by strace is preferable.

Note You need to log in before you can comment on or make changes to this bug.