Bug 208185 - fc6t3 virt-manager segfaults on launch
fc6t3 virt-manager segfaults on launch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
: 208916 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 16:53 EDT by das_deniz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 10:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested backtrace attached (3.82 KB, text/plain)
2006-09-27 13:43 EDT, das_deniz
no flags Details
similar backtrace for newer version. (3.46 KB, text/plain)
2006-09-29 18:02 EDT, das_deniz
no flags Details

  None (edit)
Description das_deniz 2006-09-26 16:53:11 EDT
Description of problem:

virtual manager segfaults on launch

Version-Release number of selected component (if applicable):

virt-manager-0.2.2-1.fc6

How reproducible:

always

Steps to Reproduce:
1. install fc6t3 + xen + updates for Tue Sep 26 15:00 EDT
2. Applications -> System Tools -> Virtual Machine Manager
3. or try virt-manager in terminal as root
  
Actual results:

# virt-manager 
dbus_bindings.DBusException Unable to determine the address of the message bus
(try 'man dbus-launch' and 'man dbus-daemon' for help)
Could not connection to session bus, disabling DBus service
/usr/share/virt-manager/virtManager/manager.py:486: Warning: value
"((GValueArray*) 0x94c9e68)" of type `GValueArray' is invalid or out of range
for property `data-array' of type `GValueArray'
  cell.set_property('data_array', data)
/usr/share/virt-manager/virtManager/manager.py:486: Warning: value
"((GValueArray*) 0x94cd0d8)" of type `GValueArray' is invalid or out of range
for property `data-array' of type `GValueArray'
  cell.set_property('data_array', data)
Segmentation fault

Expected results:

python gnome window to create/manage virtual machines... 

Additional info:

host is 2.6.18-1.2693.fc6xen #1 SMP Fri Sep 22 18:38:57 EDT 2006 i686 i686 i386
GNU/Linux

no current vms created - had created one before updates - but removed it...

also did 'mv /var/lib/xen /local'
and 'ln -s /local/xen /var/lib/xen'
to get xen vm filesystem to partition with room.
Comment 1 Daniel Berrange 2006-09-26 17:01:48 EDT
I can't reproduce this problem here anymore - the two segfaults i knew of are
both solved in latest gnome-vfs & gtk RPMs from about a week ago. Could you try
and capture a stack trace for the crash. You'll need to do something like this:

 # yum --enablerepo=development-debuginfo  install python-debuginfo,
gtk2-debuginfo & virt-manager-debuginfo  
 # ulimit -c unlimited
 # virt-manager
 # gdb /usr/bin/python core.XYZ
Comment 2 das_deniz 2006-09-27 13:43:49 EDT
Created attachment 137232 [details]
requested backtrace attached

fc6t3 + all updates till sep 27th 13:00 EDT
Comment 3 Daniel Berrange 2006-09-27 16:09:00 EDT
Thanks for the stack trace. I'm investigating the problem & have a couple of
leads which look promsing....
Comment 4 Daniel Berrange 2006-09-28 17:14:38 EDT
Committed two fixes to upstream repo for this issue

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=bf53891faa22
http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=1cb01dfe5d34

Will add patches these to next RAWHIDE update of virt-manager.
Comment 5 das_deniz 2006-09-29 18:01:15 EDT
i was going to write that not only does it no longer segfault - it now just
exits silently - but that is because i wasn't running xen on my host... (which
would be a nice message after clicking "Connect")

still - i now have virt-manager-0.2.3-1.fc6 - and it still segfaults. will
attach backtrace.
Comment 6 das_deniz 2006-09-29 18:02:18 EDT
Created attachment 137448 [details]
similar backtrace for newer version.
Comment 7 Daniel Berrange 2006-09-29 18:14:19 EDT
The fix was not in version 0.2.3-1.fc6, but I have just built a version
0.2.3-2.fc6 which will have the neccessary fix. The reason it is a sporadic
failure is because it is based on a subtle timing issue which causes the
calculated CPU utilization to go a little over 100%, which break sthe sparkline
validation, in turn resulting in a null data set which then makes the rendering
code SEGVs. Anyway, check out 0.2.3-2.fc6 once it hits rawhide (hopefully tomorrow).
Comment 8 Steve Dickson 2006-10-02 14:47:37 EDT
*** Bug 208916 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Berrange 2006-10-06 10:53:15 EDT
Closing on the basis that bug 208916 showing the same problem has reported  
0.2.3-2.fc6  fixes the issue.
Comment 10 das_deniz 2006-10-06 12:23:55 EDT
yep sorry about that - confirmed fix with the release mentioned. thank you.

Note You need to log in before you can comment on or make changes to this bug.