Bug 20825 - Crash during upgrade from 6.2 to 7.0
Crash during upgrade from 6.2 to 7.0
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 06:39 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-15 14:13:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-14 06:39:37 EST
I tried to upgrade from 6.2 to 7.0 by using the boot.img and a copy on my
HD since the netboot.img does not work !!
First I require GUI for install and get the text version.
When Anaconda starts I get the following error:
JB
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in
upgradeFindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43,
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: kernel-source
 
Local variables in innermost frame:
self: <comps.HeaderList instance at 82314b8>
item: kernel-source
 
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10
 
<failed>
Comment 1 Michael Fulbright 2000-11-15 14:13:33 EST
This is caused when something is wrong with the hard drive install image. Be
sure you downloaded all the required files in a binary safe fashion.

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.