Bug 208272 - No facility to change grub alone.
No facility to change grub alone.
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
:
: 208273 208274 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 10:56 EDT by Mike Yates
Modified: 2008-08-07 13:14 EDT (History)
0 users

See Also:
Fixed In Version: RHEL6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 13:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Yates 2006-09-27 10:56:25 EDT
Description of problem:
If grub is installed in the wrong boot-sector by mistake, during an otherwise 
successful full install, there is no way to correct this without a complete 
repeat of the install - all 4 CDs. This is because the message "No kernel 
packages have been changed so your grub will not be altered" (or some such) is 
issued, despite changes to the grub configuration being offered (and made) 
previously!
That seems to me to be plainly a bug...

I have experienced it twice now, once with Fedora5 and once with RHEL4U4 on 
servers with non-standard boot-sequences.


Version-Release number of selected component (if applicable): N/A


How reproducible: 
Very

Steps to Reproduce:
1. On a good system, boot on the install CD1 used originally.
2. Choose "upgrade" and add an extra grub option and/or change boot-drive
3. Complete "upgrade" - note message.
  
Actual results:
Changes NOT effected.

Expected results:
grub only to be changed

Additional info:
Comment 1 Jeremy Katz 2006-09-27 14:07:57 EDT
*** Bug 208273 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-09-27 14:08:07 EDT
*** Bug 208274 has been marked as a duplicate of this bug. ***
Comment 3 Mike Yates 2006-09-28 05:22:08 EDT
Sorry for the two duplicates - there seems to be a bug in your bugzilla:-

On completing entry of the bug, the nornal aknowledgement page was rapidly 
replaced by a page saying "Void or invalid Product Name - use 'Back' button to 
correct" (or some such), even though "Red Hat Enterprise Linux" had clearly 
been selected.

Obeying that instruction results in duplicates!
Comment 4 Chris Lumens 2007-11-29 14:22:40 EST
Joel - this looks like something that will be fixed up by your work on FirstAidKit.
Comment 5 Joel Andres Granados 2008-08-07 13:14:05 EDT
This is now available in the next firstaidkit version.  coming to you soon in f10 :) FYI firstaidkit 0.2.2.  And it will be in the next major RHEL release.

Note You need to log in before you can comment on or make changes to this bug.