Bug 208273 - No facility to change grub alone.
No facility to change grub alone.
Status: CLOSED DUPLICATE of bug 208272
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 10:57 EDT by Mike Yates
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 14:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Yates 2006-09-27 10:57:53 EDT
Description of problem:
If grub is installed in the wrong boot-sector by mistake, during an otherwise 
successful full install, there is no way to correct this without a complete 
repeat of the install - all 4 CDs. This is because the message "No kernel 
packages have been changed so your grub will not be altered" (or some such) is 
issued, despite changes to the grub configuration being offered (and made) 
previously!
That seems to me to be plainly a bug...

I have experienced it twice now, once with Fedora5 and once with RHEL4U4 on 
servers with non-standard boot-sequences.


Version-Release number of selected component (if applicable): N/A


How reproducible: 
Very

Steps to Reproduce:
1. On a good system, boot on the install CD1 used originally.
2. Choose "upgrade" and add an extra grub option and/or change boot-drive
3. Complete "upgrade" - note message.
  
Actual results:
Changes NOT effected.

Expected results:
grub only to be changed

Additional info:
Comment 1 Jeremy Katz 2006-09-27 14:07:35 EDT

*** This bug has been marked as a duplicate of 208272 ***

Note You need to log in before you can comment on or make changes to this bug.