Bug 208315 - Inconsistent handling of reverse IP lookup fixed in Net::DNS 0.59
Inconsistent handling of reverse IP lookup fixed in Net::DNS 0.59
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Net-DNS (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
: 208535 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-27 16:17 EDT by Dick Franks
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 14:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dick Franks 2006-09-27 16:17:56 EDT
Description of problem:
Perl-Net-DNS-0.58 resolver search(), query(), bgsend() and send() methods not
consistent in interpreting IPv4 and IPv6 addresses as a PTR query.

Version-Release number of selected component (if applicable):
0.58


Additional info:

Since FC6-test3 went to press, Net::DNS 0.59 has been released.

I realise that final release deadline is uncomfortably close, but think that the
revised module fixes enough inconsistent and outright wrong behaviour to be well
worth getting into FC6 if this is still possible.

The CPAN bug references are:

#20857  Resolver query() treats empty or undef name as default domain.

#20994  Resolver search() erroneously applies search list to IPv6 address.

#21402  Unable to prebuild PTR query from IP using Net::DNS:Packet->new().

The search() query() send() bgsend() and Packet->new() methods are now 100%
consistent in  the form of argument they accept.
The inconsistency was reported in CPAN bug #20836 (later merged with #21402)

I can confirm that revised module has been tested using FC5.
Comment 1 Robin Norwood 2006-09-27 22:52:21 EDT
I've built 0.59 as 'testing' for FC5 - I'm getting an odd error with the FC6
version that I'll investigate more in the morning.
Comment 2 Robin Norwood 2006-09-28 12:15:50 EDT
The FC6 error was my mistake - built for fc6 as well, and I've requested that
the fedora release team push this as an update to fc6.
Comment 3 Robin Norwood 2006-09-30 23:28:01 EDT
*** Bug 208535 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.