Bug 208348 - mod_perl should not provide perl(HTTP::Request::Common)
mod_perl should not provide perl(HTTP::Request::Common)
Status: CLOSED DUPLICATE of bug 197841
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-09-27 18:43 EDT by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-14 19:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix rpm auto-provides (631 bytes, patch)
2006-09-27 18:51 EDT, Christopher Stone
no flags Details | Diff

  None (edit)
Description Christopher Stone 2006-09-27 18:43:42 EDT
Description of problem:
The mod_perl package includes a .pm file which has the line:
package perl(HTTP::Request::Common);
This is on line 46 of the Apache-Test/lib/Apache/TestRequest.pm file.
Because of this, rpm thinks this file is providing perl(HTTP::Request::Common).
 This is caused by the /usr/lib/rpm/redhat/perl.prov script file.

This causes a problem, because any perl package that Requires
perl(HTTP::Reqeust::Common) is going to pick up mod_perl instead of
perl-libwww-perl like it's supposed to.

Please remove this source line from the distribution or else somehow remove the
auto-provides of perl(HTTP::Request::Common) as this is casuing problems with
all perl packages that Require this module.

Version-Release number of selected component (if applicable):
Comment 1 Christopher Stone 2006-09-27 18:51:38 EDT
Created attachment 137264 [details]
Patch to fix rpm auto-provides

This patch fixes the Provides for mod_perl to not provide
perl(HTTP::Request::Common).  Use -p0 to apply.
Comment 2 Christopher Stone 2006-09-27 19:00:37 EDT
Another alternative fix would be to just add a

Requires: perl(HTTP::Request::Common)

to the spec file.
Comment 3 Joe Orton 2006-09-29 06:56:14 EDT
Thanks for the report.  Or stripping Apache::Test from the mod_perl package per
bug 197841, that is probably the right solution.
Comment 4 Christopher Stone 2006-10-09 23:35:58 EDT
Sounds good to me.
Comment 5 Christopher Stone 2006-10-14 19:28:24 EDT
Marking as dupicate of 197841.

*** This bug has been marked as a duplicate of 197841 ***

Note You need to log in before you can comment on or make changes to this bug.