Bug 197841 - Trim test/build stuff from mod_perl
Trim test/build stuff from mod_perl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 208348 (view as bug list)
Depends On:
Blocks: finance-YahooQuote
  Show dependency treegraph
 
Reported: 2006-07-06 14:35 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 18:53:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove apache test from mod_perl (354 bytes, patch)
2006-11-23 14:23 EST, Christopher Stone
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2006-07-06 14:35:00 EDT
As discussed in private mail, in a small thread starting from me finding uses of
"use lib ..." in various mod_perl files dubious, and even potential security risks:

On Wed, 2006-07-05 at 12:01 +0100, Joe Orton wrote:

> Yeah, all of Apache::Test* could probably be stripped out of mod_perl 
> and packaged separately from the Apache::Test CPAN module.

That would make sense to me.

> Many of the ModPerl/* modules are really only used for building mod_perl 
> AFAIK; agreed again, not sure it's useful packaging these.  But I don't 
> think it's really harmful - it seems unlikely that anybody is going to 
> use any of this stuff accidentally?

Famous last words ;).  Anyway, if they're only used for building
mod_perl itself, dropping them would sound like a good idea.  Or maybe
moved to -devel.
Comment 1 Christopher Stone 2006-10-14 19:28:26 EDT
*** Bug 208348 has been marked as a duplicate of this bug. ***
Comment 2 Christopher Stone 2006-10-14 19:33:13 EDT
Joe:  This should be an easy fix, correct?  It is just a matter of removing some
files from the package?  Can we get this bug closed so I can move on with the
perl-finance-YahooQuote package?  Let me know if you need any help on this one.
 I think I should be able to modify the spec file to just remove the unwanted
files.  Should take about 15 minutes.  No reason for this bug to be open for a
quarter of a year as far as I can tell.

Thanks.
Comment 3 Christopher Stone 2006-11-18 08:40:52 EST
PING.

Hi it has been a month since I asked what the status is on this bug.

1) Another bug depends on this bug being fixed
2) This is a security related bug
3) There has been absolutely no response from Joe on this bug
4) This appears to be an extremely easy 15 minute fix as far as I can see

<rant>I know Joe that you must be busy at RedHat or extremely sick or something
because I don't see why you cannot spend twenty seconds to type some kind of
response letting us know the status of this bug.</rant>
Comment 4 Christopher Stone 2006-11-23 14:23:40 EST
Created attachment 142008 [details]
Remove apache test from mod_perl

Simple two minute fix for bug.
Comment 5 Christopher Stone 2006-12-05 10:04:59 EST
ding dong.  Hello?  Anybody home???
Comment 6 Joe Orton 2006-12-05 10:10:49 EST
Gah, sorry Chris.   I'd swear I added a comment to this a week or two ago, but I
guess I never hit "submit" :(  Excuses, excuses...

The 2.0.3 package in CVS as of yesterday started work on this - the point of
this bug was to get rid of the ModPerl::* modules not just Apache::Test; your
patch is not even sufficient for that since it misses the man pages.  2.0.3-2
isn't in pushed to Raw Hide because it has dangling deps; still working on that
(it builds).
Comment 7 Joe Orton 2006-12-05 10:11:36 EST
(the ModPerl::* stuff only dealing with the mod_perl build, that is)
Comment 8 Joe Orton 2006-12-07 09:15:35 EST
-2.0.3-3 is now in Raw Hide.  How does this look?
Comment 9 Christopher Stone 2006-12-19 00:45:13 EST
oops somehow I missed this message, I'll take a look at it tomorrow.
Comment 10 Christopher Stone 2006-12-22 12:31:45 EST
Hi, I just retested the build of bug #207864 in devel and it now builds
correctly!  So this bug is fixed as far as bug #207864 is concerned.  Will this
be built for FC5 or FC6?
Comment 11 Christopher Stone 2006-12-22 12:33:02 EST
oops I must be dyslexic, I meant to refer to bug #207846 in comment #10 :)
Comment 12 Bojan Smojver 2007-01-30 21:06:21 EST
I just tried building libapreq2-2.09-rc2 on Rawhide, but that failed, because
MM.pm cannot be found:

-------------------------------------
make[1]: Entering directory `/builddir/build/BUILD/libapreq2-2.09/glue'
cd perl; perl  Makefile.PL -apxs /usr/sbin/apxs INSTALLDIRS=vendor
Can't locate ModPerl/MM.pm in @INC (@INC contains:
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at Makefile.PL line 2.
BEGIN failed--compilation aborted at Makefile.PL line 2.
make[1]: *** [perl/Makefile] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/libapreq2-2.09/glue'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.81279 (%build)
-------------------------------------

Can we have that back?

PS. There could be other things in Perl realm that libapreq2 may need in order
to build. I'm sure Ville will be familiar with that...
Comment 13 Bojan Smojver 2007-02-07 17:07:27 EST
Ping... Any chance of a comment regarding the libapreq2 situation?
Comment 14 Joe Orton 2007-02-08 03:36:55 EST
Oh sorry, forgot to update the bug - I built -2.0.3-4 to devel last week which
restored :MM  - does it the build still fail?
Comment 15 Bojan Smojver 2007-02-08 16:14:05 EST
Unfortunately yes. Here is the new error:

------------------------------------------
Making all in glue
make[1]: Entering directory `/builddir/build/BUILD/libapreq2-2.09/glue'
cd perl; perl  Makefile.PL -apxs /usr/sbin/apxs INSTALLDIRS=vendor
Can't locate Apache2/Build.pm in @INC (@INC contains:
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/ModPerl/MM.pm line 74.
Compilation failed in require at Makefile.PL line 2.
BEGIN failed--compilation aborted at Makefile.PL line 2.
make[1]: *** [perl/Makefile] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/libapreq2-2.09/glue'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.76118 (%build)
------------------------------------------
Comment 16 Ville Skyttä 2007-02-08 18:06:49 EST
I'm getting a feeling that a good way to proceed would be to push all these
newly removed modules to the -devel subpackage instead of dropping them, as
there is obviously stuff needing them and the premise of "needed only for
building mod_perl itself" doesn't seem to hold.  BTW, my mod_perl and libapreq2
knowledge is already somewhat rusty, so don't expect too much insight from me,
at least offhand.

If the modules are restored in some package, their 'use lib ...'s should be
reviewed for buildroot remains and other dubious paths, see initial comment.
Comment 17 Bojan Smojver 2007-02-08 19:18:24 EST
Whatever makes it build again is good with me.
Comment 18 Bojan Smojver 2007-02-14 01:00:11 EST
Now it's even worse:

--------------------------------------------
This is an automated mail created by an experimental script.
Your following packages in the repository contain broken dependencies:

package: libapreq2 - 2.09-0.rc2.1.fc7.i386 from fedora-extras-development-x86_64
  unresolved deps: 
     libdb-4.3.so
--------------------------------------------
Comment 19 Kevin Fenzi 2007-02-25 16:23:18 EST
Any further word on this?

I was working on getting people to fix packages with broken deps today, and 
ran into this one. 

A current build of libapreq2 gives: 

make[1]: Entering directory `/builddir/build/BUILD/libapreq2-2.09/glue'
cd perl; perl  Makefile.PL -apxs /usr/sbin/apxs INSTALLDIRS=vendor
Can't locate Apache2/Build.pm in @INC...(lots of stuff)

Can we please get this fixed soon? I think a mod_perl-devel makes a lot of sense...

Comment 20 Joe Orton 2007-02-28 04:41:20 EST
The -7 package in CVS (and when Raw Hide pushes again, Raw Hide) implements
Ville's suggestion to restore the modules to -devel and fixes the libapreq2 build.

libapreq2 does even require Apache::Test, it seems; it could do with having some
explicit BuildRequires for perl(Apache::Test) et al.

Does anybody have time&inclination to package Apache::Test separately from the
CPAN package?  If not it can stay in mod_perl-devel.
Comment 21 Bojan Smojver 2007-02-28 15:24:05 EST
Different error this time, actually:

-------------------------------------------------
[   info] generating script t/TEST
writing...xs/APR/Request/Apache2/Apache2.xs
writing...xs/APR/Request/Apache2/Apache2.pm
mod_pod xsbuilder/APR/Request/Apache2/Apache2.pod
xsbuilder/APR/Request/Apache2/Apache2.pod 1
writing...xs/APR/Request/Apache2/Apache2.pod
writing...xs//Makefile.PL
writing...xs/APR/Makefile.PL
Writing Makefile for APR::Request::Apache2
Writing Makefile for APR::Request::CGI
Writing Makefile for APR::Request::Cookie
Writing Makefile for APR::Request::Error
Writing Makefile for APR::Request::Hook
Writing Makefile for APR::Request::Param
Writing Makefile for APR::Request::Parser
Writing Makefile for APR::Request
Writing Makefile for APR
Writing Makefile for WrapXS
Writing Makefile for libapreq2
cd perl; make
make[2]: Entering directory `/builddir/build/BUILD/libapreq2-2.09/glue/perl'
make[2]: *** No rule to make target
`/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/config.h', needed by
`Makefile'.  Stop.
make[2]: Leaving directory `/builddir/build/BUILD/libapreq2-2.09/glue/perl'
make[1]: *** [perl_glue] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/libapreq2-2.09/glue'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.4587 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.4587 (%build)
-------------------------------------------------

On FC6, this file (config.h) is part of perl package.
Comment 22 Bojan Smojver 2007-02-28 15:38:41 EST
OK, trying now with perl-devel as build dependency...
Comment 23 Bojan Smojver 2007-02-28 15:46:53 EST
OK, that was the final requirement - perl-devel. We should have libapreq2
packages now.

Thanks for you help guys!
Comment 24 Robin Norwood 2007-02-28 15:57:25 EST
The problem described in comment #21 could be the same as described in bug
#230406.  We're trying a new .spec file for perl, and it may be missing something.

See bug #226276 for the perl package review.

I suspect that perhaps this file got moved from 'perl' proper to perl-devel.
Comment 25 Bojan Smojver 2007-02-28 15:59:11 EST
Indeed it has.
Comment 26 Joe Orton 2007-02-28 18:53:08 EST
OK, marking this finally fixed, thanks for your patience.  I'm not going to
backport this to fc6 etc since it's clearly going to break stuff, but if it's
necessary for libapreq2 there too I'm open to persuasion...
Comment 27 Bojan Smojver 2007-02-28 20:40:33 EST
FC6 builds libapreq2 just fine with mod_perl-2.0.2-6.1. I just checked. So, if
things remain the way they are in FC6, it'll be all good.

Note You need to log in before you can comment on or make changes to this bug.