Bug 208370 - WIndows decorations are missing after login
WIndows decorations are missing after login
Status: CLOSED DUPLICATE of bug 212725
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
: 214080 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 01:37 EDT by mail@romal.de
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 10:14:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mail@romal.de 2006-09-28 01:37:40 EDT
Description of problem:

The window-decoration (title bar, frame, ...) are missing after login. Disabling
& enabling the 3d desktop effects do fix the problem for this session. After
logging out and on the decoration are gone again.

Version-Release number of selected component (if applicable):

Rawhide 2006-09-28 and Nvidias binary driver 9625.

How reproducible:

Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 I. Piasecki 2006-10-15 17:02:02 EDT
Me to, the same behaviour in my FC6 rawhide, nvida beta drivers:
NVIDIA-Linux-x86_64-1.0-9626
Comment 2 mail@romal.de 2006-11-06 16:26:16 EST
My installation (Rawhide 2006-11-06 and Nvidia driver 9626 from livna-repo) does
not show this bug anymore. Compiz is working flawless direct after login. Seems
to be fixed.
Comment 3 I. Piasecki 2006-11-06 17:57:04 EST
you use rawhide, but i use now FC6 (jumped from rawhide FC6 to FC6 final (Zod))
and this bug still occurs.

When i disable auto save session in GNOME, then when i login again in GNOME -
have window decoration, when i enable auto save session in GNOME - i'm waiting
for logut some time, and when login again - don't have window decoration.

I have another FC6 instalation on i386 machine and have the same problem.

I use: kmod-nvidia-1.0.9626-2.2.6.18_1.2798 from livna and the lates update for
FC6 (Zod)
Comment 4 I. Piasecki 2006-11-06 17:59:00 EST
it seems to lack of running gnome-window-decorator, when login again in GNOME.
Comment 5 Matěj Cepl 2006-11-08 10:13:53 EST
Ajax thinks that this
http://marc.theaimsgroup.com/?l=fedora-test-list&m=115901286232539&w=1 might be
relevant here.
Comment 6 Matěj Cepl 2006-11-08 10:14:43 EST
Thanks for the report.  In order for us to be able to investigate
this issue, we need you to perform the following steps.  Download
and install all xorg-x11 rpms in order to replace the xorg-x11 X
server modules that the Nvidia binary driver installation
overwrites.  This will ensure the X server finds the modules that
X.Org ships.

Once you have reinstated the Red Hat supplied X.Org modules, you
can then run "system-config-display --reconfig" which will
autodetect your video hardware and configure the correct driver,
which will either be "nv" or "vesa" depending on the specific
model you're using.  You'll now need to fully reboot the computer
in order to remove all proprietary kernel modules from the system
and restore the video hardware to its power on state.  After
this you'll need to edit the config file and manually re-enable
the COMPOSITE extension.  The experimental COMPOSITE extension
should then show up in the output of xdpyinfo, and should be
functional.  Please test this configuration and report back the
results, including file attachments of the new X server log,
config file, /var/log/messages, the output of lsmod, and
xdpyinfo.  Thanks in advance."
Comment 7 Harald Jensås 2006-11-08 10:40:18 EST
Matej just brought my attention to this bug. I submitted bug 214080 wich might 
be a duplicate of this bug.

Are you people seeing this issue only when you log in to a second X session as 
well?

Comment 8 I. Piasecki 2006-11-08 17:42:34 EST
For me it's still a bug and this is beetwen gnome-session and compiz. It's
interact one with another.

A have always windows decoration, when i login in GNOME, only when - i don't
have checked this option in gnome-session-properties: automatic save changes in
session (from polish to english).

So i don't understand, why this bug is closed, and checked NOTABUG.

I can say, i use another FC6 installation i386 and there is this behaviur the
same: after login i don't have window decorator, i run: gnome-window-decorator
and bah ! I HAVE THIS WINDOW DECORATION !

So, for me: gnome-session+compiz and gnome-window-decorator still are suspect.

When i installed my FC6 from rawhide, i installed beta drivers from nvidia.com,
not from livna. Now, i use: 
kmod-nvidia-1.0.9629-1.2.6.18_1.2798 from livna and this bug is present in my
system.


Comment 9 Harald Jensås 2006-11-09 02:37:02 EST
I. Piasecki:
Have a look at bug 214080, my FC6 system is working just fine after I moved to 
an nVidia card and the nvidia beta driver from livna.

Comment 10 Harald Jensås 2006-11-09 02:38:10 EST
*** Bug 214080 has been marked as a duplicate of this bug. ***
Comment 11 I. Piasecki 2006-11-09 02:49:55 EST
Harald Jensås:

Could you please attach your xorg.conf ? Maybe i have some missed.

Thanks.

Comment 12 Harald Jensås 2006-11-09 02:58:47 EST
I. Piasecki:

I am at work now, my FC 6 system is @ home.
Will post my X-Config when I get home this evening. Aprox 18:30 CET.
Comment 13 I. Piasecki 2006-11-09 03:09:56 EST
Ok. I'm at work too ;), So let's wait!
Comment 14 Harald Jensås 2006-11-09 13:37:00 EST
My working xorg.conf:

[harald@c-15b1e055 ~]$ cat /etc/X11/xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 20 16:56:19 PDT
2006
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
        ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"

    # generated from default
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "Emulate3Buttons" "no"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "no"
EndSection

Section "Monitor"

 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
 ### Comment all HorizSync and VertSync values to use DDC:
        Identifier   "Monitor0"
        ModelName    "LCD Panel 1280x1024"
 ### Comment all HorizSync and VertSync values to use DDC:
        HorizSync    31.5 - 67.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768"
"1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Comment 15 I. Piasecki 2006-11-10 06:45:39 EST
Thx for a xorg.conf

I have installed today FC6 at my laptop at work: acer TravelMate 4060 with intel
940 graphic chipset.

Compiz worket out of the box.

But again, when i choose option in gnome-session: save automatic changes in
session, then again, when login in GNOME, i have no windows decoration.

Another installation, another hardware - issue the same.

FC6 is fully updated.

So definetly it's a bug. Some checked this bug as NOTABUG. Wrong, this is still
a bug on my 3 fc6 instalations.
Comment 16 Matěj Cepl 2006-11-15 19:26:39 EST

*** This bug has been marked as a duplicate of 212725 ***

Note You need to log in before you can comment on or make changes to this bug.