Bug 214080 - compiz fail when starting a second Session.
compiz fail when starting a second Session.
Status: CLOSED DUPLICATE of bug 208370
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 10:12 EST by Harald Jensås
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 02:38:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Jensås 2006-11-05 10:12:02 EST
Description of problem:
I have set up KDE to start with compiz enabled by adding the following to
~/.kde/Autostart

harald@c-15b1e055 Autostart]$ cat compiz.desktop
[Desktop Entry]
Encoding=UTF-8
Exec=compiz --display $DISPLAY --replace gconf & gnome-window-decorator &
GenericName[en_US]=
StartupNotify=false
Terminal=false
TerminalOptions=
Type=Application
X-KDE-autostart-after=kdesktop


This works just fine for the first session I start. But if I use the "Switch
User - Start a new session" function in KDE to log into another X session compiz
fail. Any programs launched opens with no titlebar, so the can not be
moved/closed etc.

If I try to run desktop-effects to enable/disable the effects, this will return
an error if I try to do so in a second session.

If compiz is enabled in the first session or not does not matter.

I have also verified that the results are the same in Gnome.


Version-Release number of selected component (if applicable):
compiz-0.0.13-0.32.20060817git.fc6
xorg-x11-drv-ati-6.6.2-4.fc6

How reproducible:
Every time.

Steps to Reproduce:
1. Start a KDE or Gnome session via gdm.
2. Start a new session by using either "Switch User - Start a new session"
function in KDE or "Applications - System - New Session" in Gnome.
3. Log into the second session and try to enable desktop effects using either a
KDE Autostart file, or the desktop-effects application.
  
Actual results:
compiz only work for the first session.

Expected results:
Should be able to configure compiz to run on any given session, and on several
sessions.

Additional info:
I have also tried a Autostart file where I do not specify display for compiz,
this give me the same result.

harald@c-15b1e055 Autostart]$ cat compiz.desktop
[Desktop Entry]
Encoding=UTF-8
Exec=compiz --replace gconf & gnome-window-decorator &
GenericName[en_US]=
StartupNotify=false
Terminal=false
TerminalOptions=
Type=Application
X-KDE-autostart-after=kdesktop
Comment 1 Matěj Cepl 2006-11-08 10:03:06 EST
seems like DUP of 208370 to me
Comment 2 Harald Jensås 2006-11-08 10:35:49 EST
Matej,

I see that you in 208370, wich might be a duplicate of this, suggest people 
uninstall nVidia drivers and run on RedHat/Fedora provided x-org only.

The Ati driver I was running when I submitted the bug report are the drivers 
that came with FC6 (Zod), provided by RedHat.

---
Also in 208370 I do not see it mentioned that it only fail on a second, third, 
fourth etc. X session opened?
Comment 3 Harald Jensås 2006-11-08 13:59:04 EST
Update. This is not longer a problem for me since I switched to an nVidia
graphics card.

Currently I am running with these drivers:
xorg-x11-drv-nvidia-1.0.9626-3.lvn6
kmod-nvidia-1.0.9626-2.2.6.18_1.2798.fc6
Comment 4 Harald Jensås 2006-11-09 02:38:08 EST

*** This bug has been marked as a duplicate of 208370 ***

Note You need to log in before you can comment on or make changes to this bug.