Bug 208382 - 2.6.18 (2189) xen0 kernel in FC5-testing doesn't boot
2.6.18 (2189) xen0 kernel in FC5-testing doesn't boot
Status: CLOSED DUPLICATE of bug 211030
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 05:23 EDT by Steve Hill
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-20 15:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 206630 None None None Never

  None (edit)
Description Steve Hill 2006-09-28 05:23:20 EDT
Description of problem:


Version-Release number of selected component (if applicable):
kernel-xen0 2.6.18 (2189) from FC5-testing

How reproducible:
Always

Steps to Reproduce:
1. Install kernel
2. Reboot
  
Actual results:
Fails to mount rootfs - the boot fails with "switchroot: mount failed"

Expected results:
Boot successfully

Additional info:

References bug #206630

Unfortunately I don't have access to the console myself, so getting
any further debugging is going to be hard.

The root FS is a software RAID5 running on 3 SATA drives on the following
interfaces:
00:1f.2 IDE interface: Intel Corporation 6300ESB SATA Storage Controller (rev 02)
03:03.0 RAID bus controller: Silicon Image, Inc. Adaptec AAR-1210SA SATA
HostRAID Controller (rev 02)

This is a fairly high priority bug since Xen+iptables is broken on the kernels
currently available in the updates repository (see bug #206630) and the older,
working, kernels have been removed from updates (is there an archive of old
updates anywhere that I can get a working kernel to downgrade to in the meantime?)
Comment 1 Chris Lalancette 2006-10-01 12:10:46 EDT
Unfortunately, there is not a lot to go on here.  Do you have any more of what
the kernel printed out before getting to the "switchroot failed"?  It is
probably the case of something in the new FC5 kernel that used to be built in,
and which is now a module.  That being said, since a newer xen package hasn't
been pushed out for FC5 yet, this kernel isn't going to work for starting xen
domU's anyway.  I would suggest you look at the mirror sites and grab the older
kernel RPMS from there; if you look under "updates/5/i386" (at least on the
mirrors I am looking at), you should be able to grab the older
(2.6.17-1.2187_FC5) kernels from there.
Comment 2 Steve Hill 2006-10-01 18:42:02 EDT
Unfortunately I have no access to the server.  I _suspect_ it's not finding the
Intel SATA controller, but that's just a gut feeling.  I will dissect the initrd
when I get time to see what modules are in it.

I have a photo of the panic, unfortunately it doesn't provide much more useful
information: http://www.nexusuk.org/~steve/DSC04409.JPG

As reported in bug #206630, both the 2.6.17-1.2174_FC5 and 2.6.17-2187_FC5 xen0
kernels have seriously broken iptables, and previous kernels are nolonger
available in updates/5/x86_64.
Comment 3 Heiko Jakob 2006-10-20 15:37:02 EDT
This seems to be the same on the none xen kernel bug #211060, which is a
followup of  #211030. The raid modules got renamed on 2.6.18 and mkinitrd won't
include the new raid modules on default.

Comment 4 Dave Jones 2006-10-20 15:40:36 EDT

*** This bug has been marked as a duplicate of 211030 ***

Note You need to log in before you can comment on or make changes to this bug.