Bug 211060 - kernel-smp-2.6.18-1.2200.fc5 panics
kernel-smp-2.6.18-1.2200.fc5 panics
Status: CLOSED DUPLICATE of bug 211030
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 21:19 EDT by Jason
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-20 15:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2006-10-16 21:19:47 EDT
Description of problem:
When booting kernel-smp-2.6.18-1.2200.fc5 I receive the following output:
  Booting 'Fedora Core (2.6.18-1.2200.fc5smp)

root (hd0,0)
 Filesystem type is ext2fs, partition type 0xfd
kernel /vmlinuz-2.6.18-1.18.200.fc5smp ro root=/dev/md1 rhgb quiet
  [Linux-bzImage, setup=0x1e00, size=0x1b5ff2]
initrd /initrd-2.6.18-1.2200.fc5smp.img
  [2Linux-initrd @ 0x37eea000, 0x105ceb bytes]

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 5.0.32 starting
EXT3-fs: unable to read superblock
mount: error mounting /dev/root on /sysroot as ext3: Invalid argument
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

The error is 100% reproducable.
  
Actual results:
kernel panics

Expected results:
System should boot normally

Additional info:
I have 3 drives in my system.  md0 is a RAID 1 /boot partition formatted ext3 
of appr. 1GB on hda and hdc.  I have a 1GB swap partition on hdc.  The 
remainder of the space on all three drives is dedicated to md1 a RAID 5 
partition formatted ext3 of appr. 450GB.  hdb is a DVD-ROM/CD-RW.

kernel-smp-2.6.17-1.2187_FC5 boots normally.
Comment 1 Dave Jones 2006-10-16 21:24:33 EDT
sounds like a broken initrd.  what does your /etc/modprobe.conf look like?

Peter, any ideas?
Comment 2 Jason 2006-10-16 21:41:11 EDT
This is the contents of /etc/modprobe.conf:
cat /etc/modprobe.conf
alias eth0 8139too
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 
|| : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0

Respectfully,
Jason
Comment 3 Dave Jones 2006-10-16 21:49:53 EDT
what's the output of rpm -q lvm2 device-mapper
Comment 4 Jason 2006-10-16 21:59:39 EDT
I reported the bug.  The output from rpm -q lvm2 device-mapper:
lvm2-2.02.01-1.2.1
device-mapper-1.02.02-3.2

The configuration is exactly as the setup for FC5 created it.  The system is a 
Shuttle SB61G2 with three WD2500 drives, and a slim line DVD-ROM/CD-RW.  Other 
info that I thought may possibly help is below.  If there is anything else that 
I can post that may help, by all means please let me know.

Respectfully,
Jason


cat /etc/fstab
/dev/md1                /                       ext3    defaults        1 1
/dev/md0                /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hdd1         swap                    swap    defaults        0 0

df -kh
Filesystem            Size  Used Avail Use% Mounted on
/dev/md1              450G  226G  201G  53% /
/dev/md0              996M   41M  903M   5% /boot
tmpfs                 502M     0  502M   0% /dev/shm

mdadm --detail /dev/md1
/dev/md1:
        Version : 00.90.03
  Creation Time : Sat Jul 29 09:31:09 2006
     Raid Level : raid5
     Array Size : 486287360 (463.76 GiB 497.96 GB)
    Device Size : 243143680 (231.88 GiB 248.98 GB)
   Raid Devices : 3
  Total Devices : 3
Preferred Minor : 1
    Persistence : Superblock is persistent

    Update Time : Mon Oct 16 21:55:17 2006
          State : clean
 Active Devices : 3
Working Devices : 3
 Failed Devices : 0
  Spare Devices : 0

         Layout : left-symmetric
     Chunk Size : 256K

           UUID : 7d424b79:52262f22:339d421f:6ab6e5ae
         Events : 0.3567148

    Number   Major   Minor   RaidDevice State
       0       3        2        0      active sync   /dev/hda2
       1      22        2        1      active sync   /dev/hdc2
       2      22       66        2      active sync   /dev/hdd2

mdadm --detail /dev/md0
/dev/md0:
        Version : 00.90.03
  Creation Time : Sat Jul 29 09:42:03 2006
     Raid Level : raid1
     Array Size : 1052160 (1027.67 MiB 1077.41 MB)
    Device Size : 1052160 (1027.67 MiB 1077.41 MB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0
    Persistence : Superblock is persistent

    Update Time : Mon Oct 16 21:11:23 2006
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           UUID : 22ef254e:fa49b004:a2c998f0:89f9a5ca
         Events : 0.335

    Number   Major   Minor   RaidDevice State
       0       3        1        0      active sync   /dev/hda1
       1      22        1        1      active sync   /dev/hdc1

cat /proc/mdstat
Personalities : [raid5] [raid4] [raid1]
md0 : active raid1 hda1[0] hdc1[1]
      1052160 blocks [2/2] [UU]

md1 : active raid5 hdd2[2] hdc2[1] hda2[0]
      486287360 blocks level 5, 256k chunk, algorithm 2 [3/3] [UUU]

unused devices: <none>

00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller 
(rev 02) (prog-if 8a [Master SecP PriP])
        Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Unknown device fb61
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 169
        Region 0: I/O ports at <unassigned>
        Region 1: I/O ports at <unassigned>
        Region 2: I/O ports at <unassigned>
        Region 3: I/O ports at <unassigned>
        Region 4: I/O ports at f000 [size=16]
        Region 5: Memory at 40100000 (32-bit, non-prefetchable) [size=1K]

Comment 5 Jason 2006-10-17 18:33:22 EDT
I posted a message to the Fedora List just prior to filing this bug report, and 
have received a work around for the problem.  The information is below.

Clyde E. Kunkel wrote:
This is Bz 202596 again.

If root is on a raid 5 device, or you need raid 5 during boot, need to 
run mkinitrd --with=raid456 after booting an older FC5 kernel.  Module 
raid5 is now raid456.





Comment 6 Heiko Jakob 2006-10-20 15:32:30 EDT
this seems to be a followup bug of #211030.
#208382 seems to be the same problem on the xen0 kernel.
Comment 7 Dave Jones 2006-10-20 15:40:24 EDT

*** This bug has been marked as a duplicate of 211030 ***

Note You need to log in before you can comment on or make changes to this bug.