Bug 208421 - With compiz, yumex creates window under top panel
With compiz, yumex creates window under top panel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 214066 (view as bug list)
Depends On: 207790
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 10:32 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.2.0-1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 04:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yumex main window glade properties. (48.63 KB, image/png)
2006-10-07 03:04 EDT, Tim Lauridsen
no flags Details

  None (edit)
Description Tom London 2006-09-28 10:32:54 EDT
Description of problem:
With 'compiz' enabled, yumex creates its main window under the top panel,
preventing access to File/Edit/Profile/Tools/Help menus.

Only way I've figured to 'recover' is to right click on yumex's bottom panel
entry and select 'Move'.

Version-Release number of selected component (if applicable):
yumex-1.1.3-1.0.fc6

How reproducible:
Every time


Steps to Reproduce:
1. Enable compiz, etc.
2. Start yumex
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2006-09-29 02:25:30 EDT
Yes, i have seen this already, but i dont think it have something to do with
yumex, it a problem with compiz it should not place windows decoration under the
top panel.
Sure i can change yumex so i start in the center of the screen, but is it the
right way to do it ??.
Let me know what you think.

By the way you can use the 'Alt + Left Mouse button" to wobble the window into
place.

Comment 2 Tim Lauridsen 2006-09-29 02:36:13 EDT
Ok, there is already reported a bug against compiz with this issue.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207790
Comment 3 Tom Horsley 2006-10-06 16:16:07 EDT
I'm not sure this yumex thing is the same as bug 207790. When I
try it, it looks a lot like yumex has done something to tell compiz
to not give it any window decorations. I know there are about 2,487
"standards" for communication of info between window managers
and top level windows, and at least another 47,321 different ways
window managers interpret those 2,487 standards, so something about
yumex seems to be falling into a compiz crack. Could be yumex, could
be compiz, hard to guess who is at fault in these cases. I haven't
ever seen yumex come up with no decorations in any other window
manager though, so I'd tend to blame compiz.
Comment 4 Tim Lauridsen 2006-10-07 03:04:30 EDT
Created attachment 137966 [details]
yumex main window glade properties.
Comment 5 Tim Lauridsen 2006-10-07 03:08:07 EDT
Yumex dont do any special stuff to communicate with the windows manager, it is
just using a glade gtk window.
Comment 6 Tim Lauridsen 2006-11-07 03:04:27 EST
*** Bug 214066 has been marked as a duplicate of this bug. ***
Comment 7 szp@k 2006-11-09 15:04:20 EST
I don't use top panel, but the botom panel. When I use compiz, yumex window
opens beyond the screen, so the title bar is invisible. I cannot resize or move
this window, I can only maximize thiz window using the popup menu from the task
manager, then the title bar is visible - so there is the proper decoration of
this window.
Comment 8 Tim Lauridsen 2006-11-10 02:29:16 EST
Under compiz you can press Alt + Left Mouse button anywhere on the window to
drag it.

I think i will and some code so yumex always starts on the center of the screen.
Comment 9 Tim Lauridsen 2006-11-10 04:07:41 EST
I have changed yumex, so it always starts on the center of the screen.
It is fixed in Yum Extender 1.2.0 just released, it will hit the mirrors very soon.

Note You need to log in before you can comment on or make changes to this bug.