Bug 2085329 - kube-state-metrics is tripping APIRemovedInNextEUSReleaseInUse
Summary: kube-state-metrics is tripping APIRemovedInNextEUSReleaseInUse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.10
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.10.z
Assignee: Sunil Thaha
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 2087378 (view as bug list)
Depends On: 2085326
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-13 02:47 UTC by Scott Dodson
Modified: 2022-05-31 12:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2085326
Environment:
Last Closed: 2022-05-31 12:40:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kube-state-metrics pull 72 0 None open Bug 2085326: Use v1 PodDisruptionBudget and CronJob resources 2022-05-13 02:47:48 UTC
Red Hat Product Errata RHBA-2022:4754 0 None None None 2022-05-31 12:40:22 UTC

Description Scott Dodson 2022-05-13 02:47:13 UTC
+++ This bug was initially created as a clone of Bug #2085326 +++

kube-state-metrics is tripping APIRemovedInNextEUSReleaseInUse in 4.10 clusters because it's watching poddisruptionbudgets.v1beta1.policy.


How reproducible: always

Comment 1 Junqi Zhao 2022-05-13 06:53:29 UTC
tested with the PR#72, no APIRemovedInNextEUSReleaseInUse alert
# token=`oc sa get-token prometheus-k8s -n openshift-monitoring`
# oc -n openshift-monitoring exec -c prometheus prometheus-k8s-0 -- curl -k -H "Authorization: Bearer $token" 'https://thanos-querier.openshift-monitoring.svc:9091/api/v1/query?query=ALERTS' | jq '.data.result[].metric | {alertname,alertstate}'
{
  "alertname": "AlertmanagerReceiversNotConfigured",
  "alertstate": "firing"
}
{
  "alertname": "Watchdog",
  "alertstate": "firing"
}

Comment 4 Simon Pasquier 2022-05-18 08:45:10 UTC
*** Bug 2087378 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2022-05-31 12:40:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.16 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:4754


Note You need to log in before you can comment on or make changes to this bug.