This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 208708 - xen host kernel makes host serial ports unusable
xen host kernel makes host serial ports unusable
Status: CLOSED DUPLICATE of bug 204825
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Markus Armbruster
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-30 11:48 EDT by Frank Ch. Eigler
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 09:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2006-09-30 11:48:34 EDT
Description of problem:
A fc6xen host kernel hides the host ttyS0/ttyS1 ports from the 8250*
drivers.  This makes any devices connected there, like UPSs or whatnot,
unreachable to the host OS.

Version-Release number of selected component (if applicable):
2.6.17-1.2630.fc6

How reproducible:
always

Steps to Reproduce:
1. examine dmesg log
2. note how 8250 driver is not loaded, even for ttyS1 ...
3. try to load 8250 driver, note it fails
Comment 1 Frank Ch. Eigler 2006-10-05 16:16:09 EDT
This may be a duplicate of bug #180126.
I'll test some of the dom0 hacks suggested there ("xencons=off", "sync_console")
and report back.
Comment 2 Frank Ch. Eigler 2006-10-05 22:06:03 EDT
Booting the dom0 kernel with xencons=tty, then manually loading the 8250 driver
works: it restores access to the host serial ports.  Should this be documented
or automated?
Comment 4 Markus Armbruster 2007-03-28 09:54:38 EDT

*** This bug has been marked as a duplicate of 204825 ***

Note You need to log in before you can comment on or make changes to this bug.