Bug 208712 - video out of range on graphical install from rescue CD on PowerPC
video out of range on graphical install from rescue CD on PowerPC
Status: CLOSED DUPLICATE of bug 231359
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-30 13:04 EDT by John Reiser
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 18:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/ramfs/X.log upon failure (43.41 KB, text/plain)
2006-09-30 13:04 EDT, John Reiser
no flags Details
Xorg.0.log from good boot of previous FC5 system (50.12 KB, text/plain)
2006-09-30 13:06 EDT, John Reiser
no flags Details
lspci output (8.38 KB, text/plain)
2006-09-30 13:07 EDT, John Reiser
no flags Details
/tmp/Xconfig.test (771 bytes, text/plain)
2006-09-30 13:24 EDT, John Reiser
no flags Details
/tmp/ramfs/X.log (42.83 KB, text/plain)
2006-10-03 15:20 EDT, John Reiser
no flags Details
/tmp/ramfs/X.log (42.45 KB, text/plain)
2006-12-14 12:24 EST, John Reiser
no flags Details
XConfig.text (771 bytes, text/plain)
2006-12-14 12:25 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-09-30 13:04:33 EDT
Description of problem: Using today's rescue CD to install via "boot: linux" on
a PowerPC Apple Macintosh mini, the external LCD monitor hardware detects "Out
of range" and/or displays "staircase" rasters (pitch is wrong by 32 pixels).


Version-Release number of selected component (if applicable):
anaconda-11.1.0.102-1
7fc0e7c8edeb5b20b75f571565276bf862c9ff8a  FC-development-ppc-rescuecd.iso

How reproducible:
always

Steps to Reproduce:
1. boot: linux
2. language, keyboard, HTTP, DHCP, IPv4 only, mirror, directory
3.
  
Actual results:
Monitor hardware detects "Out of range" and/or displays staircase rasters (pitch
is wrong by 32 pixels) when displaying the first graphics screen


Expected results:
Correct graphics.

Additional info:
Comment 1 John Reiser 2006-09-30 13:04:33 EDT
Created attachment 137482 [details]
/tmp/ramfs/X.log upon failure
Comment 2 John Reiser 2006-09-30 13:06:36 EDT
Created attachment 137483 [details]
Xorg.0.log from good boot of previous FC5 system

1024x768 @ 75Hz
Comment 3 John Reiser 2006-09-30 13:07:31 EDT
Created attachment 137484 [details]
lspci output

lspci; lspci -n; lspci -v -v
Comment 4 John Reiser 2006-09-30 13:24:58 EDT
Created attachment 137485 [details]
/tmp/Xconfig.test
Comment 5 Adam Jackson 2006-10-03 12:23:53 EDT
Should be fixed in xorg-x11-drv-ati 6.6.2-4 and later.  Please test, and reopen
this bug if it's still a problem for you.  Thanks!
Comment 6 John Reiser 2006-10-03 15:20:22 EDT
Created attachment 137688 [details]
/tmp/ramfs/X.log

Note that the hsync of
-----
(II) RADEON(0): <default monitor>: Using default hsync range of 31.50-37.90 kHz

(II) RADEON(0): <default monitor>: Using default vrefresh range of 50.00-70.00
Hz
-----
looks narrow to me, but the default mode lines
-----
(**) RADEON(0): *Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(II) RADEON(0): Modeline "800x600"   40.00  800 840 968 1056  600 601 605 628
+hsync +vsync
(**) RADEON(0):  Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(II) RADEON(0): Modeline "800x600"   36.00  800 824 896 1024  600 601 603 625
+hsync +vsync
(**) RADEON(0):  Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
-----
seem to be OK.
Comment 7 John Reiser 2006-10-03 15:21:10 EDT
The problem persists in today's Rescue CD.  About 8 seconds after starting X
server, the LCD monitor hardware says "Out of range".  I wait for 3 minutes to
be sure everything is quiescent [the CD has not made the usual seeking noise for
over 2 minutes, and there is no other inidication of business].  Then, switching
among VT1, VT2, VT3, VT4, and VT6 using <ctrl><alt><Fn> shows that the text
consoles VT1-4 work, and the graphics console VT6 works (displays the Welcome
graphics screen, and never in staircase mode) about 15% to 20% of the time; but
mostly the graphics console displays the hardware-detected "Out of range".
The Rescue CD is:
8734c546b422b27eea3c89182f69aa76335dda46  FC-development-ppc-rescuecd.iso

rawhide report: 20061003 changes says:
=====
xorg-x11-drv-ati-6.6.2-4.fc6
----------------------------
* Mon Oct 02 2006 Adam Jackson <ajackson@redhat.com> 6.6.2-4
    . . .
- radeon-6.6.2-usefbdev-patch.patch: Use the framebuffer stride from fbdev,
  instead of making up numbers.  (#208694)
=====
so apparently it has the version named in Comment #5.

I will attach /tmp/ramfs/X.log.
Comment 8 John Reiser 2006-12-14 12:22:34 EST
The problem persists with the final release DVD for Fedora Core 6.  I will
attach XConfig.test and X.log.
Comment 9 John Reiser 2006-12-14 12:24:31 EST
Created attachment 143665 [details]
/tmp/ramfs/X.log

X.log from FC6 DVD for PowerPC (32-bit Apple Macintosh mini).
Comment 10 John Reiser 2006-12-14 12:25:47 EST
Created attachment 143666 [details]
XConfig.text

XConfig.test from FC6 DVD for PowerPC (32-bit Apple Macintosh mini)
Comment 12 Adam Jackson 2007-04-02 18:03:47 EDT

*** This bug has been marked as a duplicate of 231359 ***

Note You need to log in before you can comment on or make changes to this bug.