This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 231359 - (radeon-none-none) Radeon driver doesn't get BIOS data correctly
Radeon driver doesn't get BIOS data correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 186119 187821 208712 212762 229136 232496 233727 235403 238689 244777 (view as bug list)
Depends On:
Blocks: 715588
  Show dependency treegraph
 
Reported: 2007-03-07 15:52 EST by Adam Tkac
Modified: 2013-04-30 19:35 EDT (History)
12 users (show)

See Also:
Fixed In Version: 6.7.192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 08:03:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
(In reply to comment #18) (52.07 KB, text/plain)
2007-05-10 09:02 EDT, Adam Tkac
no flags Details
X log from Acer laptop with the patched driver (6.73 KB, text/plain)
2007-05-17 14:17 EDT, Daniel Qarras
no flags Details
Generated X config on Acer laptop with the patched driver (823 bytes, text/plain)
2007-05-17 14:18 EDT, Daniel Qarras
no flags Details
lspci -vvv says this about my card (1.71 KB, text/plain)
2007-05-22 07:59 EDT, Adam Tkac
no flags Details

  None (edit)
Description Adam Tkac 2007-03-07 15:52:01 EST
Description of problem:
I have mobility radeon x700 graphics card in my notebook. When I try start Xorg
with default configuration I could see nice output - nothing

Version-Release number of selected component (if applicable):
rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.6.3-2.fc7

How reproducible:
always when X has default configuration

Steps to Reproduce:
For all developers
 - 1. steal one ATI's mobility radeon x700
   2. try start Xorg with default configuration
   3. see output (black screen)

For ajax :)
 - 1. beg from me to access to my notebook
   2. beg again because first begging wasn't successful
   3. see steps to reproduce for all developers
  
Actual results:
black screen

Expected results:
working X

Additional info:
 - after ajax's investigations my bios lies to driver about monitor - says NONE
 - could be hacked when I add <Option "MonitorLayout" "LVDS,NONE"> to driver section
Comment 1 Adam Jackson 2007-04-02 17:51:17 EDT
*** Bug 233727 has been marked as a duplicate of this bug. ***
Comment 2 Adam Jackson 2007-04-02 17:52:40 EDT
*** Bug 229136 has been marked as a duplicate of this bug. ***
Comment 3 Adam Jackson 2007-04-02 18:03:50 EDT
*** Bug 208712 has been marked as a duplicate of this bug. ***
Comment 4 Adam Jackson 2007-04-02 18:14:50 EDT
*** Bug 187821 has been marked as a duplicate of this bug. ***
Comment 5 Adam Jackson 2007-04-06 13:55:42 EDT
*** Bug 212762 has been marked as a duplicate of this bug. ***
Comment 6 Adam Jackson 2007-04-09 11:27:33 EDT
*** Bug 232496 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2007-04-10 16:31:11 EDT
*** Bug 186119 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Qarras 2007-04-14 12:15:03 EDT
This problem still exists with Fedora 7 Test 3: tried the live CD and when the
system startup was finished all I saw was a blank screen. Switching to runlevel
3 and running system-config-display resulted also just a blank screen.

Bug 187821 has details about my system.
Comment 9 Daniel Qarras 2007-04-21 09:23:08 EDT
FWIW, Ubuntu 7.04 works perfectly on my laptop where both FC6/F7T3 fail.
Comment 10 Daniel Qarras 2007-04-29 07:45:16 EDT
This is still broken with Fedora 7 Test 4 (6.93) but works all ok with Ubuntu 7.04.
Comment 11 Adam Jackson 2007-05-08 15:53:01 EDT
*** Bug 235403 has been marked as a duplicate of this bug. ***
Comment 12 Adam Jackson 2007-05-08 16:51:30 EDT
Checking over 7.04 I see one patch that might be relevant.

Test rpm build with that patch applied:

http://koji.fedoraproject.org/koji/getfile?taskID=5111&name=xorg-x11-drv-ati-6.6.3-2.fc7.jx.x86_64.rpm
http://koji.fedoraproject.org/koji/getfile?taskID=5112&name=xorg-x11-drv-ati-6.6.3-2.fc7.jx.i386.rpm

Pick the one appropriate for your arch and test please.
Comment 13 Bruno Wolff III 2007-05-08 18:25:31 EDT
Can we just do an update and log out and back in (to restart the X server) to
test this? Or do we need to do a new install of F7?
Comment 14 John Reiser 2007-05-08 19:01:53 EDT
Bug #208712 (video out of range on graphical install from rescue CD on PowerPC),
which is marked as a duplicate of this bug #231359, is already fixed in the
FC-development Rescue CD-ROM for PowerPC of 2007-05-08, 131104768 bytes, sha1sum
f4098ed0db0965a2346b05df4da7160ce77ad8b0, even without trying those .rpm
mentioned in Comment #12 (and those do not include ppc [32-bit PowerPC] anyway.)
Comment 15 Bruno Wolff III 2007-05-08 23:47:50 EDT
I tested this by booting into F7, installing the i386 rpm above, removed
/etc/X11/xorg.conf and rebooted back into F7. My monitor was not detected, same
as previuosly.
I can still fix things by manually setting the monitor to NEC LCD2010X, logging
out, then changing the resolution to the native 1280x1024 for the monitor. For
some reason when I first change the monitor type, I can't also increase the
resolution (it is at 800x600), but after the first login it changes to 1920x1280
which doesn't make sense to me. Either it should stay at 800x600 or one would
think the monitor definition would have the prefered resolution (or at least
aspect ratio) and not just blindly pick the highest resolution supported by both
the video card and the monitor or whatever method it uses to pick the new
resolution.
Comment 16 Adam Tkac 2007-05-09 07:49:02 EDT
(In reply to comment #12)
still badly broken on my x86_64. I dug around and found interesting comment. See
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/22985/comments/115

Regards, -A-
Comment 17 Adam Jackson 2007-05-09 10:17:43 EDT
(In reply to comment #16)
> (In reply to comment #12)
> still badly broken on my x86_64. I dug around and found interesting comment. See
>
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/22985/comments/115
> 
> Regards, -A-

Yeah, that's the patch I added.  Bleh.  Need to figure this one out.
Comment 18 Adam Jackson 2007-05-09 10:25:47 EDT
Also, if someone could attach an X log from running the patched driver, that'd help.
Comment 19 Adam Tkac 2007-05-10 09:02:42 EDT
Created attachment 154468 [details]
(In reply to comment #18)
Comment 20 Adam Tkac 2007-05-10 09:06:46 EDT
(In reply to comment #18)
You've got it. But it looks that there's nothing interesting in log.

rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.6.3-2.fc7.jx

-A-
Comment 21 Adam Jackson 2007-05-11 17:15:52 EDT
*** Bug 238689 has been marked as a duplicate of this bug. ***
Comment 22 Daniel Qarras 2007-05-17 14:13:55 EDT
Great news! The x86 RPM mentioned in Comment #12 solves the problem most on my
Acer laptop! Running Fedora 6.93 with following updates system-config-display
works and identifies my laptop display and also X works. Bug 187821 has details
about my system. Please consider pushing this fix to F7!

xorg-x11-drv-ati-6.6.3-2.fc7.jx
xorg-x11-server-Xorg-1.3.0.0-5.fc7

However, with those updates I still see following hickups:

- system-config-display offers resolutions 640x400 and 800x600 although Windows
XP reports using 1200x800 which I also believe being correct
- X seems to be using ideal resolution but when closing GNOME/X, display freezes
with last view showed and I need to do Alt-Ctrl-F1 to get back to console.
Starting X again works all ok, though.

Otherwise no problems.
Comment 23 Daniel Qarras 2007-05-17 14:17:08 EDT
Created attachment 154946 [details]
X log from Acer laptop with the patched driver
Comment 24 Daniel Qarras 2007-05-17 14:18:15 EDT
Created attachment 154947 [details]
Generated X config on Acer laptop with the patched driver
Comment 25 Adam Tkac 2007-05-22 07:58:32 EDT
(In reply to comment #22)
I've created i386 livecd with patched driver (i386 version) and this also
doesn't work in my case. Looks that you've got different version of graphics
firmware

-A-
Comment 26 Adam Tkac 2007-05-22 07:59:51 EDT
Created attachment 155157 [details]
lspci -vvv says this about my card
Comment 27 Daniel Qarras 2007-05-31 16:57:27 EDT
FWIW, this is still broken with Fedora 7 (but still works all ok with Ubuntu 7.04).
Comment 28 Jacek Piskozub 2007-06-22 05:02:01 EDT
The patched rpm from comment 12 saved the day on my Acer Travelmate 4100 with X700
Comment 30 Jacek Piskozub 2007-06-22 06:28:38 EDT
I'll add that I lost graphics completely after a yum update to f7 (dark screen,
no possibility of setting up the graphics with either radeon or vesa). Comment
12 rpm  was the solution.
Comment 31 Matěj Cepl 2007-06-29 10:26:20 EDT
After being one of the most duplicate bugs in Red Hat bugzilla, it may be time
to make this bug ASSIGNED, right? ;-)
Comment 32 Adam Jackson 2007-08-27 16:55:32 EDT
The radeon output detection code has been dramatically overhauled in 6.7.192,
which is currently headed to rawhide.  Anyone affected by this bug please test
it and report any failures here.
Comment 33 Daniel Qarras 2007-08-28 11:09:13 EDT
Oh, dear God, tears are coming from my eyes, it works finally! Thank you!

Seriously, though, a bit more complete report below including a way to get a
hang every time:

1) running system-config-display now finally works and if I just use the default
config created also the driver works perfectly. Config looks sane, no anything
especial there. So far so good.

2) however, when running system-config-display only resolution 800x600 can be
selected. So I was tempted to change monitor from autoconfigured to a 1200x800
LCD display and selecting 1200x800 resolution. With that xorg.conf I get almost
immediate system hangs after starting X and few applications.

In case 2) there's both new Monitor section and Modes setting under Display
section, also option "dpms" in the Monitor section. Commenting only "dpms" out
still hangs. When commenting out only Modes line I get only blank screen when
starting X. But when both "dpms" and Modes lines are commented out, everything
is working all ok again.

So clear progress here but for an unsuspecting user a great chance to get hanging X.

For details about my system please see Bug 187821.

Thanks.
Comment 34 Matěj Cepl 2007-08-28 12:54:43 EDT
Reporter, could you confirm please, that this is really resolved?
Comment 35 Adam Tkac 2007-08-29 02:41:02 EDT
Nice work, monitor detection is now correct
Comment 36 Adam Jackson 2007-10-01 16:21:53 EDT
*** Bug 244777 has been marked as a duplicate of this bug. ***
Comment 37 Jens Petersen 2007-10-03 04:01:12 EDT
Would it make sense to clone a bug of this for F7?
Comment 38 Dave Airlie 2007-10-03 20:15:48 EDT
I acutally don't think we can fix this in F7 in any reasonable fashion.

The reason this is fixed in F8 is a brand new ATI driver which drops support for
some of the older features like mergedfb/dual-head, so shipping the new driver
in F7 updates would break peoples existing setups..

We can't backport the fix either as the older driver is limited by its own
architecture.
Comment 39 Bruno Wolff III 2007-10-04 00:20:59 EDT
For the problems I was having, there isn't any point to fixing F7. I only had a
problem on first boot and once I manually set up the xorg configuration I didn't
have to futz with it again. I don't plan on doing any more F7 installs, so just
having a fix in F8 is OK with me.
Comment 40 Jens Petersen 2007-10-04 01:10:28 EDT
Agreed - I just asked since there was talk of an update earlier
and this bug is already closed rawhide. :)

Note You need to log in before you can comment on or make changes to this bug.