Bug 208819 - [RFE] Enable running 32-bit firefox on x86_64
[RFE] Enable running 32-bit firefox on x86_64
Status: CLOSED DUPLICATE of bug 425951
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 03:00 EDT by Zoltan Boszormenyi
Modified: 2007-12-17 09:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 09:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Enable running 32-bit firefox on 64-bit (443 bytes, patch)
2006-10-02 03:00 EDT, Zoltan Boszormenyi
no flags Details | Diff

  None (edit)
Description Zoltan Boszormenyi 2006-10-02 03:00:33 EDT
Description of problem:

/usr/bin/firefox always starts 64-bit Firefox if both arch is installed.

Version-Release number of selected component (if applicable):

all

How reproducible:

always

Steps to Reproduce:
1. run /usr/bin/firefox
2.
3.
  
Actual results:


Expected results:


Additional info:

I modified /usr/bin/firefox script so if it encounters "ff32"
as first argument then it doesn't consider /usr/lib64/firefox*.
This argument is then gets forgotten and usual processing continues.
This should be integrated to the "default applications" framework
so one should be able to just select "Firefox (32-bit, plugin-compatible)"
from the drop-down list on an x86-64 system.
Comment 1 Zoltan Boszormenyi 2006-10-02 03:00:34 EDT
Created attachment 137521 [details]
Enable running 32-bit firefox on 64-bit
Comment 2 Göran Uddeborg 2006-11-10 05:47:10 EST
This would be a useful feature as long as there are plugins that are only
available in 32 bit version.

Another suggestion for how to do it:  Check if MOZ_LIB_DIR is set in the
environment, and don't override it if it is.
Comment 3 Matěj Cepl 2007-12-17 09:05:31 EST

*** This bug has been marked as a duplicate of 425951 ***

Note You need to log in before you can comment on or make changes to this bug.