Bug 425951 - Request ability to force firefox to use 32 bit version on 64 bit systems
Request ability to force firefox to use 32 bit version on 64 bit systems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
: 208819 221765 465436 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 07:24 EST by Neil Horman
Modified: 2008-10-03 07:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 11:28:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /usr/bin/firefox to allow MOZ_ARCH to be overridden (484 bytes, patch)
2007-12-17 07:24 EST, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2007-12-17 07:24:47 EST
Description of problem:
It would be nice if firefox on x86_64 had a mechanism whereby individual users
could select if they used the 64 or 32 bit version of firefox when they had both
installed.  This would allow for the use of 32 bit only plugins on 64 bit
systems without having to repoint desktop icons at the 32 bit specific variant
of firefox.
Comment 1 Neil Horman 2007-12-17 07:24:47 EST
Created attachment 289775 [details]
patch to /usr/bin/firefox to allow MOZ_ARCH to be overridden
Comment 2 Matěj Cepl 2007-12-17 09:05:32 EST
*** Bug 208819 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Cepl 2007-12-17 09:05:40 EST
*** Bug 221765 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Cepl 2007-12-17 09:16:04 EST

*** This bug has been marked as a duplicate of 295411 ***
Comment 5 Neil Horman 2007-12-17 09:40:33 EST
I really don't think this is a duplicate of the bug that you marked it a
duplicate of.  295411 indicates that the devel repositories don't have both x86
and x86_84 variants of firefox, but that doesn't seem to be true:

http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/Packages/firefox-2.0.0.10-5.fc9.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/Packages/firefox-2.0.0.10-5.fc9.x86_64.rpm

So, contrary to bug 295411 we have both arches in the x86_64 repository.  And
while nspluginwrapper is nice, it really doesn't always work sufficiently well.
 While we obviously need to make that the way forward, it really would be nice
to have a way to switch back to 32 bit firefox transparently.  Perhaps 295411
needs to be the place to do that, I'm not sure
Comment 6 Christopher Aillon 2007-12-17 11:03:15 EST
setarch i386 firefox
Comment 7 Neil Horman 2007-12-17 11:11:55 EST
yes, thats rather the point.  Our repositories allow us to have both firefox
arches installed on an x86_64 distribution, but we don't offer any easy way to
switch between the two without directly specifying the version we want to run.

Whats the argument against including this ability?
Comment 8 Christopher Aillon 2007-12-17 11:28:47 EST
setarch i386 firefox

That IS the way to do it.  We allow you to have multiple binaries of many other
items in the distro, and that is ALSO the way to switch the bitness. Firefox is
not going to get special behavior here.  Either you don't know about bitness
because you just are a normal user that doesn't concern themselves with such
things, or you are geeky enough to know what bitness you want, and are able to
type 'setarch i386'.  Feel free to make a launcher if you want for your personal
machine.
Comment 9 Neil Horman 2007-12-17 11:43:34 EST
my misunderstanding.  I thought you were referring to the setarch command in yum
during package installation.
Comment 10 Zoltan Boszormenyi 2007-12-25 01:36:31 EST
Okay, so "setarch i386 firefox" is the way to do it. Did you actually
try it? Not from a terminal, but by setting the default browser in GNOME.
It is buggy. When Firefox is selected from the list, the custom command
entry  says "firefox %s" and is greyed out. Pressing the browser button
on the upper panel brings up firefox and my initial pages, it's ok.
When I set the default browser manually to a custom browser (no matter
if it's "/usr/bin/firefox %s" or "setarch i386 firefox %s") then pressing
the browser button on the panel brings up firefox with the correct bitness,
that's ok. But it doesn't bring up my initial pages, instead it goes to search
for "www.s.com". Perhaps "%s" gets misinterpreted. Pressing the "home" button
brings my initial pages but it's annoying that I need another mouseclick.
Comment 11 Matěj Cepl 2008-10-03 07:01:57 EDT
*** Bug 465436 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.