Bug 209224 - Review Request: prelude-manager - Prelude Management server
Review Request: prelude-manager - Prelude Management server
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Package Reviews List
:
Depends On: 209214
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-10-03 17:42 EDT by Thorsten Scherf
Modified: 2017-01-31 10:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 11:19:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2006-10-03 17:42:58 EDT
Spec URL: http://people.redhat.com/tscherf/fedora-extra/
SRPM URL: http://people.redhat.com/tscherf/fedora-extra/
Description: 
Prelude Manager is the main program of the Prelude Hybrid IDS
suite. It is a multithreaded server which handles connections from
the Prelude sensors. It is able to register local or remote
sensors, let the operator configure them remotely, receive alerts,
and store alerts in a database or any format supported by
reporting plugins, thus providing centralized logging and
analysis. It also provides relaying capabilities for failover and
replication. The IDMEF standard is used for alert representation.
Support for filtering plugins allows you to hook in different
places in the Manager to define custom criteria for alert relaying
and logging.

This is my first package and I need a sponsor.
Comment 1 Jason Tibbitts 2006-10-03 19:09:33 EDT
I've set FE-NEEDSPONSOR as appropriate.  Any chance you could give us direct
links to the spec files and src.rpms?

Also, are there really no interdependencies between all of these prelude
packages?  If there are, could you indicate which package depends on which in
the "depends on" and "blocks" fields so that these can be considered and
reviewed in the proper order.

Thanks.
Comment 2 Thorsten Scherf 2006-10-03 19:16:49 EDT
all packages are available via the link mentioned in the initial post.

dependencies are as follows:

libprelude
 -> libpreludedb
    -> libpreludedb-plugins
 -> prelude-lml
 -> prelude-manager
    -> prelude-manager-plugins
 
Comment 3 Jason Tibbitts 2006-10-03 20:56:13 EDT
Perhaps I wasn't sufficiently clear.
 
Any chance you could give us direct links to the spec files and src.rpms?  I.e.
a URL that when clicked on immediately opens the spec file, and a URL that when
clicked on immediately downloads the src.rpm, for each package.

Also, could you please indicate which package depends on which in the "depends
on" and "blocks" fields of these bugzilla tickets so that they can be considered
and reviewed in the proper order?

Reviewer time is limited, and the number of available sponsors is limited even
further.  A couple of minutes spent properly submitting your packages for review
can make the difference between them getting dealt with quickly and them sitting
around for months.

Thanks!
Comment 6 Mamoru TASAKA 2006-12-30 00:15:09 EST
(removing NEEDSPONSOR)
Comment 8 Mamoru TASAKA 2007-01-04 12:18:01 EST
Well, for 0.9.7.1-1:

* For Requires/BuildRequires
  - libpreludedb-devel requires libprelude-devel, so writing
    both "libpreludedb-devel libprelude-devel" is redundant.

  - gnutls-devel is required by libprelude-devel

  - Why does -devel package require libtool?

* Scriptlets
  - For initscript treatment
    Please add the proper Requires(post), etc. according to
    "Services" of
    http://fedoraproject.org/wiki/Packaging/ScriptletSnippets .

  - And, if you don't want to do "condrestart" on %postun,
    please explain why (in some cases, condrestart treatment
    is unwilling)

* Directory ownership issue
  - /usr/share/prelude-manager/ is not owned by any package.

* Encoding
--------------------------------------------------
/usr/share/doc/prelude-manager-0.9.7.1/ChangeLog:  ISO-8859 English text
--------------------------------------------------

* Debuginfo issue
--------------------------------------------------
+ /usr/lib/rpm/find-debuginfo.sh /builddir/build/BUILD/prelude-manager-0.9.7.1
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/bin/prelude-manager
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/fi
lters/idmef-criteria.so
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/reports/db.so
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/reports/xmlmod.so
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/reports/textmod.so
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/reports/debug.so
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/reports/relaying.so
extracting debug info from
/var/tmp/prelude-manager-0.9.7.1-1.fc7-root-mockbuild/usr/lib/prelude-manager/decodes/normalize.so
cpio: prelude-manager-0.9.7.1/src/.libs/prelude-managerS.c: No such file or
directory
594 blocks
----------------------------------------------------
  Perhaps modifying ltmain.sh as prelude-lml works?
Comment 10 Mamoru TASAKA 2007-01-05 11:01:11 EST
For 0.9.7.1-2:

* For Requires/BuildRequires:
-------------------------------------------
BuildRequires:  gnutls-devel, libpreludedb-devel, libxml2-devel
-------------------------------------------
  - "gnutls-devel" is not needed because
         libpreludedb-devel requires libprelude-devel
     and libprelude-devel requires gnutls-devel

* Filesystem Layout
  - Please install initscript service file into
    %{_sysconfdir}/rc.d/init.d , not %{_sysconfdir}/init.d .

    For this file:
-------------------------------------------
install -m 750 %{_builddir}/%{name}-%{version}/%{name}.initd
%{buildroot}/%{_sysconfdir}/init.d/%{name}
-------------------------------------------
    - %{_builddir}/%{name}-%{version}/ is not needed
      because the working directory at this stage is there.
    - Why do you write "750"? Anyway the permission of
      this script is set as 0755 accroding to %file section
      and it should be 0755.

* Directory/file ownership
  - Oops, %{_libdir}/prelude-manager/ is not owned by any packages.
Comment 11 Mamoru TASAKA 2007-01-05 11:38:13 EST
I also found:
* Conditional dependencies
-------------------------------------------
*** Dumping configuration ***
    - TCP wrapper support    : no
    - XML plugin support     : yes
    - Database plugin support: yes
-------------------------------------------
Is this okay?

Mockbuild log says:
-------------------------------------------
checking tcpd.h usability... no
checking tcpd.h presence... no
checking for tcpd.h... no
-------------------------------------------
For FC-devel, tcpd.h is provided by tcp_wrappers-devel,
For FC-6 and below, it is provided by tcp_wrappers
Comment 12 Paul Howarth 2007-01-05 11:53:33 EST
(In reply to comment #10)
> * Filesystem Layout
>   - Please install initscript service file into
>     %{_sysconfdir}/rc.d/init.d , not %{_sysconfdir}/init.d .

%{_initrddir} can also be used for this.
Comment 13 Ralf Corsepius 2007-01-06 00:41:18 EST
(In reply to comment #11)
> I also found:
> * Conditional dependencies
> -------------------------------------------
> *** Dumping configuration ***
>     - TCP wrapper support    : no
>     - XML plugin support     : yes
>     - Database plugin support: yes
> -------------------------------------------
> Is this okay?
No. This means building the rpm is non-deterministic.

Does the package have an --enable-tcp-wrapper configure option or similar? Then
you might want to apply this.

If not, you will probably want to add
BuildRequires: tcp_wrappers-devel
or
BuildConflicts: tcp_wrappers-devel
for FC > 6, rsp.

BuildRequires: tcp_wrappers
or
BuildConflicts: tcp_wrappers
for FC <= 6

depending on if you want to use tcp_wrappers or not.
Comment 14 Thorsten Scherf 2007-01-07 17:31:45 EST
* Sun Jan 07 2007 Thorsten Scherf <tscherf@redhat.com> 0.9.7.1-3
- added tcp-wrapper support
- fixed dirowner and permissions problem


updated packages are available:
http://people.redhat.com/tscherf/fedora-extra/prelude-manager-0.9.7.1-3.src.rpm
http://people.redhat.com/tscherf/fedora-extra/prelude-manager.spec

Comment 15 Mamoru TASAKA 2007-01-08 10:44:31 EST
Well, one issue.
As I said in comment #11, activating TCP wrapper support needs
* For FC-devel: tcp_wrappers-devel
* For FC5/6: tcp_wrappers
for BuildRequires.

You can change the BuildRequies according to FC-devel <-> FC 5/6 by
--------------------------------------------
BuildRequires:  libpreludedb-devel, libxml2-devel
%if 0%{?fedora} > 6
BuildRequires:  tcp_wrappers-devel
%else
BuildRequires:  tcp_wrappers
%endif
--------------------------------------------

Other things are all okay.
--------------------------------------------------------
  This package (prelude-manager) is APPROVED by me.
Comment 16 Thorsten Scherf 2007-01-08 11:19:42 EST
fixed and closed.

Note You need to log in before you can comment on or make changes to this bug.