Bug 209254 - tar-1.15.1-17 segmentation fault
tar-1.15.1-17 segmentation fault
Status: CLOSED DUPLICATE of bug 208701
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-10-03 23:08 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-04 04:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-10-03 23:08:28 EDT
tar-1.15.1-17 segmentation faults when extracting files


take /usr/src/redhat/SOURCES/openssl-0.9.7f-usa.tar.bz2  from FC4

/usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/openssl-0.9.7f-usa.tar.bz2 >b
gdb tar
(gdb) run -xf b
Starting program: /bin/tar -xf b
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x635000
[Thread debugging using libthread_db enabled]
[New Thread -1208957248 (LWP 24032)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208957248 (LWP 24032)]
xattrs_xattrs_set (st=0xbfcefe8c,
    file_name=0x8866aec "openssl-0.9.7f/test/randtest.c", typeflag=50 '2')
    at xattrs.c:386
386               keyword += strlen("SCHILY.xattr.");
(gdb) bt
#0  xattrs_xattrs_set (st=0xbfcefe8c,
    file_name=0x8866aec "openssl-0.9.7f/test/randtest.c", typeflag=50 '2')
    at xattrs.c:386
#1  0x08052624 in set_stat (
    file_name=0x8866aec "openssl-0.9.7f/test/randtest.c", st=0xbfcefe8c,
    cur_info=0x0, invert_permissions=0, permstatus=UNKNOWN_PERMSTATUS,
    typeflag=50 '2') at extract.c:296
#2  0x0805309a in extract_finish () at extract.c:1240
#3  0x0806117b in main (argc=3, argv=0xbfcf00c4) at tar.c:1761
#4  0x00668d7f in __libc_start_main () from /lib/libc.so.6
#5  0x0804ab91 in _start ()

This is tar-1.15.1-17 which is compiled and run on FC4
Comment 1 Need Real Name 2006-10-03 23:12:56 EDT
Looks this is related to xattr support
commenting in SPEC 
#%patch15 -p1 -b .xattrs
everythings starts working OK
Comment 2 Peter Vrabec 2006-10-04 04:23:04 EDT

*** This bug has been marked as a duplicate of 208701 ***

Note You need to log in before you can comment on or make changes to this bug.