Bug 209389 - sane-backends-devel content does not look right
sane-backends-devel content does not look right
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
:
: 213448 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 21:08 EDT by Henrik Nordstrom
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 09:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.25 KB, patch)
2006-10-04 21:30 EDT, Henrik Nordstrom
no flags Details | Diff

  None (edit)
Description Henrik Nordstrom 2006-10-04 21:08:35 EDT
Description of problem:

sane-backends-devel contains only 2 headers and lots of .so links for the
individual backends. Would expect a lot more headers, and less .so links.. The
current content is not very helpful as it is not sufficient for sane-backends
development.

missing include/sane/sanei_* & sane/config.h

the /usr/lib64/sane/ .so links should not be needed. These are never referenced
directly outside sane.

sanei_*.h needs to be cleaned up a bit to fixup the include references. #include
"../include/sane/XXX.h" should be #include <sane/XXX.h>

perl -i -p -e 's%"../include/(.*\.h)"%<$1>%' `fgrep -l '"../include' *.h`

Version-Release number of selected component (if applicable):

sane-backends-devel-1.0.18-2.fc6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Henrik Nordstrom 2006-10-04 21:30:41 EDT
Created attachment 137791 [details]
Proposed patch

The attached specfile patch attempts to clean up the devel package as outlined
earlier.

Verified by manually building the avision backend out-of-tree.

Could be cleaned up by fixing sane-backends to install the required files
proper instead of doing it manually from the spec file.
Comment 2 Nils Philippsen 2007-07-24 03:43:35 EDT
*** Bug 213448 has been marked as a duplicate of this bug. ***
Comment 3 Nils Philippsen 2007-11-07 09:41:49 EST
I won't overrule upstream on this one, therefore I'll close this bug as UPSTREAM.

The corresponding upstream bug is:

https://alioth.debian.org/tracker/index.php?func=detail&aid=306658&group_id=30186&atid=410366

Note You need to log in before you can comment on or make changes to this bug.