Bug 209401 - Anaconda errors install cairo
Anaconda errors install cairo
Status: CLOSED DUPLICATE of bug 192663
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cairo-java (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 02:50 EDT by Colin Coe
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 14:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Coe 2006-10-05 02:50:06 EDT
Description of problem:
RHEL5 BETA 1 Client install aborts due to xxxx with cairo package

Version-Release number of selected component (if applicable):
RHEL5 BETA 1 Client

How reproducible:

Steps to Reproduce:
1. Kickstart install RHEL5 BETA 1 Client with '*' as the package list
  
Actual results:
ERROR : error running transaction: file /usr/share/java/cairo1.0-src-1.05.zip 
from install of cairo-java-devel-1.0.5-1.fc6 conflicts with file from package 
cairo-java-1.0.5-1.fc6
ERROR : error running transaction: file /usr/share/java/cairo1.0-src-1.0.5.zip 
from install of cairo-java-devel-1.0.5.fc6 conflicts with file from package 
cairo-java-1.0.5-1.fc6

Expected results:
The install of cairo should have completed successfully.

Additional info:
Kickstart config file with %pre follows:
lang en_US
keyboard us
timezone --utc Australia/Perth
rootpw --iscrypted uncbG6OkNC2PI
reboot
install
firstboot --disabled
monitor --noprobe
nfs --server=10.240.34.254 --dir=/export/install/el5b1_x86_64 --
opts="nfsvers=3,tcp,rsize=32768,wsize=32768"
bootloader --location=mbr
%include /tmp/clearpart.cfg
%include /tmp/partition.cfg
authconfig --enableshadow --useshadow
network --bootproto=dhcp --device=eth0
selinux --disabled
firewall --disabled
skipx
text
%packages --ignoremissing
%include /tmp/packages.cfg

%pre
#!/bin/bash -x

export wel_type=""
export wel_auth=""
export wel_update=0
export INSTALL_PATH="/export/install"
export NFS_SERVER="10.240.34.254"

# Kludge so xargs works
[ ! -x /bin/echo ] && ln -s /usr/bin/echo /bin/echo

# The format of /proc/partitions changes between kernels and grep is missing 
some handy switches
export DRIVES=`fdisk -l | awk '/^Disk/ {print $2}' | sed 's/://g'`
export COUNT=`echo ${DRIVES} | wc -w | sed 's/ //g'`

echo "Parsing '/proc/cmdline'"
for ARG in `cat /proc/cmdline`; do
        echo ${ARG} | grep -q "wel_"
        [ $? -eq 0 ] && eval `echo $ARG | cut -d= -f1`=`echo $ARG | cut -d= -f2`
done

> /tmp/clearpart.cfg
> /tmp/packages.cfg
> /tmp/partition.cfg

# Preserve SSH and RHN info between builds
echo "Looking for / file system on ${PART}"
LABEL="`e2label /dev/sda3 2> /dev/null`"
if [ "${LABEL}" = "/" ]; then
        echo "Found / file system"
        IP=`ifconfig eth0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1`
        HOST=`nslookup ${IP} | grep -i name | sed 's/ //g' | cut -d: -f2 | cut -
d. -f1`
        echo "Host $HOST ($IP)"
        ROOT="/tmp/root"
        NFS="/tmp/wel"
        SSH="${ROOT}/etc/ssh"
        RHN="${ROOT}/etc/sysconfig/rhn"
        HOME="${ROOT}/root/.ssh"
        mkdir ${ROOT}
        mkdir ${NFS}
        mount -t nfs -o rw ${NFS_SERVER}:${INSTALL_PATH} ${NFS}
        mount -t ext2 -o ro ${PART} ${ROOT}
        if [ -f "${RHN}/systemid" -a ! -f ${NFS}/${HOST}_sysconfig_rhn.cpio ]; 
then
                echo "Found RHN info"
                ( cd ${RHN} ; find . ) | cpio --create > ${NFS}/${HOST}
_sysconfig_rhn.cpio
        fi
        if [ -f "${SSH}/ssh_host_key" -a ! -f ${NFS}/${HOST}_ssh.cpio ]; then
                echo "Found SSH info"
                ( cd ${SSH} ; find . ) | grep -v "_config" | cpio --create > 
${NFS}/${HOST}_ssh.cpio
        fi
        if [ -f "${HOME}/authorized_keys" -a ! -f ${NFS}/${HOST}
_root_ssh.cpio ]; then
                echo "Found root's ssh info"
                ( cd ${HOME} ; find . ) | cpio --create > ${NFS}/${HOST}
_root_ssh.cpio
        fi
        umount ${ROOT}
        umount ${NFS}
fi


if [ ${wel_type} = "lws" ]; then
        TYPE=Workstation
        MP=/vmware
else
        TYPE=Cluster
        MP=/local/dsk
fi

echo "${TYPE} partition config..."
parted -s /dev/sda mklabel msdos
echo "
n
p
1
1
+100M
n
p
2

+16G
n
p
3

+40G
t
3
82
n
p
4

+20G
w
" | fdisk /dev/sda
echo "part /boot --fstype ext3 --asprimary --onpart sda1" >> /tmp/partition.cfg
echo "part / --fstype ext3 --asprimary --onpart sda2" >> /tmp/partition.cfg
echo "part swap --asprimary --onpart sda3" >> /tmp/partition.cfg
echo "part ${MP} --fstype ext3 --asprimary --onpart sda4" >> /tmp/partition.cfg

I=0
for DRIVE in ${DRIVES}; do
        echo ${DRIVE} | grep -q sda && continue
        I=$((I+1))
        echo "Checking drive ${DRIVE}"
        if [ `fdisk -l ${DRIVE} | grep "^/" | wc -l | sed 's/ //g'` -ne 1 ]; 
then
                [ -z "${CLEARPART}" ] && CLEARPART=`basename ${DRIVE}` || 
CLEARPART="${CLEARPART},`basename ${DRIVE}`"
                if [ ${COUNT} -eq 2 ]; then
                        echo "part /local/data --fstype ext3 --asprimary --
ondisk `basename ${DRIVE}` --size 1 --grow" >> /tmp/partition.cfg
                elif [ ${COUNT} -gt 2 ]; then
                        echo "part raid.${I} --size 1 --grow --ondisk `basename 
${DRIVE}`" >> /tmp/partition.cfg
                        RAID="${RAID} raid.${I}"
                fi
        else
                echo "${DRIVE} looks OK"
        fi
done
echo "clearpart --drives ${CLEARPART} --initlabel" >> /tmp/clearpart.cfg
grep -q raid /tmp/partition.cfg && echo "raid /local/data --level=0 --
device=md0 ${RAID}" >> /tmp/partition.cfg

echo "*" >> /tmp/packages.cfg
Comment 1 Jeremy Katz 2006-10-05 10:52:59 EDT
This is a package bug 
Comment 3 Stepan Kasal 2006-10-05 14:48:29 EDT
Bug #192663, which was causing this, has been fixed.
Comment 4 Stepan Kasal 2006-10-06 04:40:15 EDT

*** This bug has been marked as a duplicate of 192663 ***

Note You need to log in before you can comment on or make changes to this bug.