Bug 209479 - Possible usability improvements to "Locating installation media" page
Possible usability improvements to "Locating installation media" page
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
Brian Brock
:
Depends On:
Blocks: 211233
  Show dependency treegraph
 
Reported: 2006-10-05 11:38 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 17:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the page (30.48 KB, image/png)
2006-10-05 11:38 EDT, Dave Malcolm
no flags Details

  None (edit)
Description Dave Malcolm 2006-10-05 11:38:47 EDT
Description of problem:
"Locating installation media" page has two URL fields: Install media URL,and an
optional kicksart URL.

Is there a way of minimizing the amount of URLs that need to be entered here? 
Will it have history of previous URLs that you have typed here?  (it's not quite
as bad as anaconda since at least you can copy and paste from a browser window)  

In particular, can there be:
- an option to install from local media?  (autodetected, so it knows if you have
a CD/DVD in the drive)
- for RHEL, knowledge about RHN or the satellite server you installed from, and
give the option to select a distro/kickstart from this server? 
One feature of RHN is the ability to store kickstart profiles:
https://rhn.redhat.com/rhn/help/reference/rhn410/en/s1-sm-systems.jsp#S2-SM-SYSTEM-KICKSTART
Should they be displayed here?

I can't see a way of doing this via the API:
  https://rhn.redhat.com/rhn/apidoc/
(though I guess the API can be expanded)

Version-Release number of selected component (if applicable):
virt-manager-0.2.3-2.fc6
Comment 1 Dave Malcolm 2006-10-05 11:38:47 EDT
Created attachment 137825 [details]
Screenshot of the page
Comment 2 Dave Malcolm 2006-10-05 11:40:54 EDT
Sorry to file RHEL-specific stuff under Fedora; maybe this bug should be split
up and the RHEL part moved to a new bug under the correct "Product"?
Comment 3 Daniel Berrange 2006-10-06 11:06:17 EDT
We already have plans to add support for remembering the last 'N' URLs entered. 

In theory we could support install of CD, but there is no way to change CD's
when the guest VM is running in paravirt guests, so for now that'll probably
lead to more problems that it solves.

So, for this bug we'll address the URL history. Could you enter a separate bug
for RHN integration - it is something that'll need much more
thought/investigation to decide to best way to approach it.
Comment 4 Hugh Brock 2006-10-18 15:42:34 EDT
Added URL history to both fields
Comment 5 Daniel Berrange 2006-10-24 17:35:26 EDT
Fixed in rawhide in build  virt-manager-0.2.5-1.fc7 

Note You need to log in before you can comment on or make changes to this bug.