Bug 209507 - AttributeError: 'AnacondaYumRepo' object has no attribute 'getAttributeKeys' install FC-devel on ia64
AttributeError: 'AnacondaYumRepo' object has no attribute 'getAttributeKeys' ...
Status: CLOSED DUPLICATE of bug 209462
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 13:47 EDT by Greg Edwards
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 13:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Edwards 2006-10-05 13:47:53 EDT
Description of problem:

Attempting an NFS install of current ia64 fedora-devel on Altix ia64,
I got an anaconda traceback just after finishing all the pre-installation
settings (partitioning, eth0 config, etc).

Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 177, in __init__
    if v or not k in self.getAttributeKeys():
  File "/usr/lib/anaconda/yuminstall.py", line 365, in doConfigSetup
    root = root)
  File "/usr/lib/anaconda/yuminstall.py", line 329, in __init__
    self.doConfigSetup(root=anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 650, in doInitialSetup
    self.ayum = AnacondaYum(anaconda)
  File "/usr/lib/anaconda/backend.py", line 148, in doRepoSetup
    anaconda.backend.doInitialSetup(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 540, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 956, in ?
    anaconda.intf.run(anaconda)
AttributeError: 'AnacondaYumRepo' object has no attribute 'getAttributeKeys'


How reproducible:

Haven't tried reproducing it yet (will do that next).

Steps to Reproduce:
1. tftpboot initrd and vmlinuz from boot.img
2. point at nfs install repo of fedora-devel (just synced from mirrors.kernel.org)
3. go through pre-install settings
Comment 1 Prarit Bhargava 2006-10-05 13:52:36 EDT

*** This bug has been marked as a duplicate of 209462 ***

Note You need to log in before you can comment on or make changes to this bug.