Bug 209462 - traceback in text mode
Summary: traceback in text mode
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 209507 210197 210198 210260 210264 210267 210438 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-05 14:30 UTC by Florian La Roche
Modified: 2007-11-30 22:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 14:47:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file from fatal exception trying to net install rawhide of 10/10/06 (230.88 KB, text/plain)
2006-10-10 17:10 UTC, Clyde E. Kunkel
no flags Details
anaconda dump file (renamed) from net install attemp of rawhide 20061013 (111.91 KB, text/plain)
2006-10-13 20:16 UTC, Clyde E. Kunkel
no flags Details

Description Florian La Roche 2006-10-05 14:30:19 UTC
Description of problem:

Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 177, in __init__
    if v or not k in self.getAttributeKeys():
  File "/usr/lib/anaconda/yuminstall.py", line 365, in doConfigSetup
    root = root)
  File "/usr/lib/anaconda/yuminstall.py", line 329, in __init__
    self.doConfigSetup(root=anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 650, in doInitialSetup
    self.ayum = AnacondaYum(anaconda)
  File "/usr/lib/anaconda/backend.py", line 148, in doRepoSetup
    anaconda.backend.doInitialSetup(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 540, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 956, in ?
    anaconda.intf.run(anaconda)
AttributeError: 'AnacondaYumRepo' object has no attribute 'getAttributeKeys'



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2006-10-05 14:47:11 UTC
Fxed

Comment 2 Prarit Bhargava 2006-10-05 17:53:01 UTC
*** Bug 209507 has been marked as a duplicate of this bug. ***

Comment 3 Clyde E. Kunkel 2006-10-10 17:09:37 UTC
Today's rawhide (10/10/2006) may have similar or same problem. Seeing:
AttributeError: 'AnacondaYumRepo' object has no attribute '_AnacondaYumRepo__get'

Attaching anaconda dump file.

Comment 4 Clyde E. Kunkel 2006-10-10 17:10:57 UTC
Created attachment 138163 [details]
anaconda dump file from fatal exception trying to net install rawhide of 10/10/06

Comment 5 Chris Lumens 2006-10-10 17:25:56 UTC
Fixed again.

Comment 6 Chris Lumens 2006-10-10 19:11:59 UTC
*** Bug 210198 has been marked as a duplicate of this bug. ***

Comment 7 Chris Lumens 2006-10-10 19:12:18 UTC
*** Bug 210197 has been marked as a duplicate of this bug. ***

Comment 8 Chris Lumens 2006-10-11 14:20:58 UTC
*** Bug 210267 has been marked as a duplicate of this bug. ***

Comment 9 Chris Lumens 2006-10-11 14:21:32 UTC
*** Bug 210264 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2006-10-11 14:36:52 UTC
*** Bug 210260 has been marked as a duplicate of this bug. ***

Comment 11 Chris Lumens 2006-10-12 14:11:40 UTC
*** Bug 210438 has been marked as a duplicate of this bug. ***

Comment 12 Craig Kelley 2006-10-12 21:13:13 UTC
Is this bug supposed to be fixed in rawhide?  I'm still seeing bug 210267 on 10/12.

Comment 13 David Miller 2006-10-12 22:01:58 UTC
I was about to ask the same question.  Bugs shouldn't be "CLOSED" until the fix
is really installed in the tree and verified, I've been trying rawhide for 2
days waiting for this to be "really" fixed.


Comment 14 Mark Smith 2006-10-13 04:09:37 UTC
For ppc64, I saw this bug's stack trace on 10/10 rawhide, 
but on 10/11  duplicated 210352, a slightly different trace.  
Today, 10/12's rawhide, all appears fixed; my two install tests succeeded.

Comment 15 David Miller 2006-10-13 05:07:46 UTC
I just retried today's images and they appear to be going fine so far,
so it appears to be fixed here too.


Comment 16 Clyde E. Kunkel 2006-10-13 20:16:11 UTC
Created attachment 138459 [details]
anaconda dump file (renamed) from net install attemp of rawhide 20061013

I believe this is a different bug, however, from rawhide 20061013 net install,
fatal exception:
AttributeError: YumAvailablePackageSqlite instance has no attribute 'returnEVR'


May be related to yum-3.0.5 problems in this rawhide.


Note You need to log in before you can comment on or make changes to this bug.