Bug 209513 - gjdoc requires antlr on classpath
Summary: gjdoc requires antlr on classpath
Status: CLOSED DUPLICATE of bug 209595
Alias: None
Product: Fedora
Classification: Fedora
Component: gjdoc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-05 18:30 UTC by Anthony Green
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 18:48:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anthony Green 2006-10-05 18:30:39 UTC
Description of problem:
When I build the kawa SRPM, I need to add antlr to the classpath in order 
for gjdoc to run.  Isn't there some other way to force antlr in there so users
don't have to add it manually?

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install the kawa SRPM from devel
2.remove antlr from the classpath
3.build it
  
Actual results:


Expected results:


Additional info:

Comment 1 Andrew Overholt 2006-10-05 21:59:03 UTC
antlr.jar *is* on the gjdoc classpath.  It's not a Requirement of it, though. 
I've fixed this and pushed a build.  Hopefully we can get this into FC6 or at
least soon afterwards as an update.

Comment 2 Anthony Green 2006-10-06 00:01:01 UTC
antlr.jar is not on the classpath in my test case.  See...

https://www.redhat.com/archives/fedora-devel-java-list/2006-October/msg00003.html

Note that in my case the code is being invoked directly by ant, isn't it?


Comment 3 Tom Tromey 2006-10-06 00:08:44 UTC
I'm under the impression that ant execs javadoc, and does not
try to invoke it directly.  I haven't looked at the code to
verify this, however.  Still, there's nothing in that stack trace
that indicates ant.


Comment 4 Stepan Kasal 2006-10-06 09:43:07 UTC
Bug 209595 might be related to this.

Comment 5 Andrew Overholt 2006-10-06 18:48:28 UTC
I *think* this is a dupe.  If not, please re-open, Anthony.

*** This bug has been marked as a duplicate of 209595 ***


Note You need to log in before you can comment on or make changes to this bug.