Bug 209621 - anaconda fails during upgrade from FC4 to FC6
anaconda fails during upgrade from FC4 to FC6
Status: CLOSED DUPLICATE of bug 206913
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 09:37 EDT by Marco Bill-Peter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 09:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda stack trace (131.69 KB, application/octet-stream)
2006-10-06 09:37 EDT, Marco Bill-Peter
no flags Details

  None (edit)
Description Marco Bill-Peter 2006-10-06 09:37:11 EDT
Description of problem:

anaconda fails during upgrade from FC4 to FC6 (see stack trace)

Version-Release number of selected component (if applicable):


How reproducible:

every time - I was not able to upgrade at all, had to do a fresh install


Steps to Reproduce:
1. Choose upgrade existing FC installation
2. 
3.
  
Actual results:

raceback (most recent call first):
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 612, in tagByName
    raise Errors.MiscError, "Unknown header tag %s" % tag
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 629, in returnSimple
    return self.tagByName(thing)
  File "/usr/lib/anaconda/sortedtransaction.py", line 17, in __getMedia
    uri = po.returnSimple('basepath')
  File "/usr/lib/anaconda/sortedtransaction.py", line 42, in add
    id = self.__getMedia(txmember.po)
  File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 255, in
addErase
    self.add(txmbr)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1950, in remove
    txmbr = self.tsInfo.addErase(po)
  File "/usr/lib/anaconda/yuminstall.py", line 959, in doPostSelection
    self.ayum.remove(name=pkgname, arch=pkgarch)
  File "/usr/lib/anaconda/backend.py", line 154, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 919, in nextClicked
    self.anaconda.dispatch.gotoNext()
MiscError: Unknown header tag basepath

Local variables in innermost frame:
self: system-config-mouse - 1.2.11-1.noarch
tag: basepath
e: 'unknown header tag'

see full stack trace as attachment

Expected results:

anaconda not exiting

Additional info:
Comment 1 Marco Bill-Peter 2006-10-06 09:37:12 EDT
Created attachment 137914 [details]
Anaconda stack trace
Comment 2 Chris Lumens 2006-10-06 09:43:19 EDT

*** This bug has been marked as a duplicate of 206913 ***

Note You need to log in before you can comment on or make changes to this bug.