Bug 20984 - installing LILO into root=boot partition - itself beyond cylinder 1024 gives "no space" message incorrectly
installing LILO into root=boot partition - itself beyond cylinder 1024 gives ...
Status: CLOSED DUPLICATE of bug 14351
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-16 17:31 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-17 15:26:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-16 17:31:25 EST
1)Had trouble with poor error message which assumes that a bios originated
"write" failure
is due to the target partition not having enough disk. Actually partition
had enough space
but the root partition was beyond cylinder 1024 (motherboard=Intel OR840).
Had to guess 
this might be the cause.
2)Using the nice GUI "back" button each time after a "no space" error to
fdisk reformat after 3 times and finally placing the root partition below
cyl 1024 the anaconda GUI broke messily, 
mumbling about device error. It seems there is a "leak" of some kind that
is not reset after a
failure message and hitting the "back" button all the way to fdisk screen.
Anyway a hard
reboot and filling in all the numbers again caused all to work (once the
partition table was OK).

Incidently, the disk scenario is 2*30GB drives, one with NT & win98 the
other with Linux 7.0.

Repeat this by purposefully putting /root beyond cyl 1024 and telling LILO
to write itself there 
(and NOT the MBR). Then watch the install fail (after an optional format),
click "back" until
fdisk screen, fiddle and then return to install. Repeat another couple of
times, with last time
making a /root partition below cyl 1024, observe the crash. 

This install was about as difficult as installing NT and win98 on same
disk. You are close to
being easier than Microsoft !
Comment 1 Michael Fulbright 2000-11-17 12:09:13 EST
Passing to QA to reproduce.
Comment 2 Brock Organ 2000-11-17 14:56:20 EST
this problem is verified ... replacing the "linear" line by "lba32" in the
lilo.conf allows you to have your /boot above 1024 cylinders, BUT the anaconda
installer does not do this ...

thanks for your report!
Comment 3 Michael Fulbright 2000-11-17 15:26:05 EST
Essentially the same as bug 14351.

*** This bug has been marked as a duplicate of 14351 ***

Note You need to log in before you can comment on or make changes to this bug.