Bug 20985 - cant install
Summary: cant install
Status: CLOSED DUPLICATE of bug 19523
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: ia64 Linux
high
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 22:38 UTC by Need Real Name
Modified: 2018-09-19 07:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 15:56:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda stack dumped... (880 bytes, patch)
2000-11-16 22:40 UTC, Need Real Name
no flags Details | Diff

Description Need Real Name 2000-11-16 22:38:57 UTC
<!It told me to save this to disk. I cant even use linux because it gives 
me this error.>

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in 
makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Need Real Name 2000-11-16 22:40:02 UTC
Created attachment 5461 [details]
anaconda stack dumped...

Comment 2 Michael Fulbright 2000-11-17 16:57:36 UTC
This is a dupe of bug 19523.

Please give the steps required for us to reproduce this problem on your system.

Comment 3 Michael Fulbright 2000-12-04 15:56:38 UTC

*** This bug has been marked as a duplicate of 19523 ***

Comment 4 Brock Organ 2000-12-21 19:37:59 UTC
There is an update disk that should fix this. Download it, gzip it, dd (or
 rawrite) it to a floppy disk. When you boot into the install, specify "linux
 updates" at the boot prompt. The install will prompt you to install this floppy
 when it needs it.

 ftp://people.redhat.com/ewt/mountupd.img.gz

 It should fix this problem. Please reopen this bug if it doesn't.

Comment 5 openshift-github-bot 2018-09-19 07:46:43 UTC
Commits pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/dbd3a2f95dee82766f43416c259275329af8aa70
Issue #20985 Don't mount the docker/config.json if file doesn't exist

Signed-off-by: Praveen Kumar <kumarpraveen.nitdgp@gmail.com>

https://github.com/openshift/origin/commit/de0de626ace9e47bd8c62607233613952d8e9847
Merge pull request #21019 from praveenkumar/issue_20985

Issue #20985 Don't mount the docker/config.json if file doesn't exist


Note You need to log in before you can comment on or make changes to this bug.