Bug 19523 - here the summary that the installer gives hope that u fix it
here the summary that the installer gives hope that u fix it
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
: 19366 19527 19579 20240 20329 20896 20985 21118 21407 21622 21826 21960 22114 22115 22275 22284 22458 22803 22879 22991 23673 23719 23805 24952 25099 25106 27215 27670 28147 31623 32577 32827 33575 36604 36718 36818 44201 46877 47969 54234 57442 59373 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-21 15:35 EDT by solracv
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 18:35:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description solracv 2000-10-21 15:35:13 EDT
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in 
makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-30 14:11:46 EST
Could you please gives the steps we need to take to reproduce this problem?
Comment 2 Michael Fulbright 2000-10-30 14:13:49 EST
*** Bug 19527 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2000-10-30 14:50:19 EST
*** Bug 19579 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2000-11-03 14:56:12 EST
*** Bug 20240 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2000-11-07 10:20:26 EST
*** Bug 20329 has been marked as a duplicate of this bug. ***
Comment 6 Jeremey Davis 2000-11-07 18:42:45 EST
Yes, all you need to do (or so I would assume) is attempt to do a partionless installation of Linux 7.0 onto a system with Win98 as the current OS. That's 
what I'm trying to do and this is driving me insane. I've tried all the other Anaconda fixes and none of them help this annoyance.
Comment 7 Panic 2000-11-08 10:49:33 EST
I've been working with webmaster on this -- hardware information:

Aptiva, Pentium MMX (unknown speed)
32MB
IBM 3.2GB HD (ATA-33? probably Mode 4)
IDE controller is an Intel 82371SB PCI Bus Master as described by Windows
video is a Mach64 variant with 512kB RAM
Sound is Crystal Audio (ISA PnP), possibly with a additional IDE controller

He has 1.7 GB free on his FAT32 partition, and is attempting a partitionless
install (which we know).  From what we've done so far, it is unclear where
exactly the installation is failing. If he's willing, I'll work with him to
provide some more detailed information.

Matt
Comment 8 Panic 2000-11-09 14:45:11 EST
Update on webmaster's situation:

He has a P200MMX.

The Anaconda error is occurring at the attempt to create the loopback
filesystem.  In the F4 virtual terminal, he has this error:

Error: Not Ready
(reserved error code) -- (ase=0x3a, ascq=0x01)
(Sense Key = 0x02)
The Fail "Read Cd/Dvd Capacity" packet command was: "25 00 00 00 00 00 00 00 00
00 00 00"

He does have two CD drives, a normal CD-ROM and a CD-RW.  I'm assuming at this
point that he is installing from the normal CD-ROM.  This affects all the
installation types: Workstation, Server, and Custom.
Comment 9 Michael Fulbright 2000-11-14 15:17:13 EST
Ok this is looking like a hardware issue. Is it possible to switch out the CDROM
drive and try another to see if it is caused by hardware.
Comment 10 Michael Fulbright 2000-11-20 15:05:09 EST
*** Bug 21118 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2000-12-04 10:53:56 EST
*** Bug 20896 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2000-12-04 10:56:34 EST
*** Bug 20985 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2000-12-04 11:59:00 EST
*** Bug 21622 has been marked as a duplicate of this bug. ***
Comment 14 Michael Fulbright 2000-12-06 18:09:18 EST
*** Bug 21826 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2000-12-12 11:43:38 EST
*** Bug 22114 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2000-12-12 11:45:00 EST
*** Bug 22115 has been marked as a duplicate of this bug. ***
Comment 17 Michael Fulbright 2000-12-14 11:33:49 EST
*** Bug 22284 has been marked as a duplicate of this bug. ***
Comment 18 Michael Fulbright 2000-12-14 11:49:07 EST
*** Bug 22275 has been marked as a duplicate of this bug. ***
Comment 19 Brock Organ 2000-12-18 16:30:46 EST
this error occurs when attempting a partitionless install that requires a
package from the 2nd CD ...
Comment 20 Michael Fulbright 2000-12-19 11:28:48 EST
*** Bug 22458 has been marked as a duplicate of this bug. ***
Comment 21 Michael Fulbright 2000-12-19 14:50:52 EST
*** Bug 21407 has been marked as a duplicate of this bug. ***
Comment 22 Erik Troan 2000-12-21 14:33:37 EST
There is an update disk that should fix this. Download it, gzip it, dd (or
rawrite) it to a floppy disk. When you boot into the install, specify "linux
updates" at the boot prompt. The install will prompt you to install this floppy
when it needs it.

ftp://people.redhat.com/ewt/mountupd.img.gz

It should fix this problem. Please reopen this bug if it doesn't.
Comment 23 Erik Troan 2000-12-21 15:03:37 EST
*** Bug 22561 has been marked as a duplicate of this bug. ***
Comment 24 Michael Fulbright 2000-12-27 12:12:00 EST
*** Bug 22803 has been marked as a duplicate of this bug. ***
Comment 25 Michael Fulbright 2001-01-03 18:35:13 EST
*** Bug 22991 has been marked as a duplicate of this bug. ***
Comment 26 Brock Organ 2001-01-09 14:57:04 EST
this issue is resolved in the current internal test trees and will appear in the
next release ... thanks for your report!
Comment 27 Michael Fulbright 2001-01-09 16:52:11 EST
*** Bug 23673 has been marked as a duplicate of this bug. ***
Comment 28 Michael Fulbright 2001-01-10 16:29:52 EST
*** Bug 23719 has been marked as a duplicate of this bug. ***
Comment 29 Michael Fulbright 2001-01-11 11:35:42 EST
*** Bug 21960 has been marked as a duplicate of this bug. ***
Comment 30 Michael Fulbright 2001-01-12 10:27:25 EST
*** Bug 23805 has been marked as a duplicate of this bug. ***
Comment 31 Michael Fulbright 2001-01-15 19:56:23 EST
*** Bug 19366 has been marked as a duplicate of this bug. ***
Comment 32 Michael Fulbright 2001-01-19 16:49:51 EST
*** Bug 22879 has been marked as a duplicate of this bug. ***
Comment 33 Michael Fulbright 2001-01-25 17:28:51 EST
*** Bug 24952 has been marked as a duplicate of this bug. ***
Comment 34 Michael Fulbright 2001-01-29 19:41:57 EST
*** Bug 25106 has been marked as a duplicate of this bug. ***
Comment 35 Michael Fulbright 2001-01-29 19:42:56 EST
*** Bug 25099 has been marked as a duplicate of this bug. ***
Comment 36 Michael Fulbright 2001-02-20 12:30:59 EST
*** Bug 27670 has been marked as a duplicate of this bug. ***
Comment 37 Michael Fulbright 2001-02-20 14:38:30 EST
*** Bug 28147 has been marked as a duplicate of this bug. ***
Comment 38 Michael Fulbright 2001-02-21 18:15:55 EST
*** Bug 27215 has been marked as a duplicate of this bug. ***
Comment 39 Michael Fulbright 2001-03-21 15:21:06 EST
*** Bug 31623 has been marked as a duplicate of this bug. ***
Comment 40 Michael Fulbright 2001-03-22 10:44:00 EST
*** Bug 32577 has been marked as a duplicate of this bug. ***
Comment 41 Michael Fulbright 2001-03-26 16:13:50 EST
*** Bug 32827 has been marked as a duplicate of this bug. ***
Comment 42 Michael Fulbright 2001-03-29 12:02:40 EST
*** Bug 33575 has been marked as a duplicate of this bug. ***
Comment 43 Brent Fox 2001-04-19 16:00:21 EDT
*** Bug 36604 has been marked as a duplicate of this bug. ***
Comment 44 Brent Fox 2001-04-20 09:06:03 EDT
*** Bug 36818 has been marked as a duplicate of this bug. ***
Comment 45 Brent Fox 2001-04-21 09:01:29 EDT
*** Bug 36718 has been marked as a duplicate of this bug. ***
Comment 46 Brent Fox 2001-06-12 12:32:41 EDT
*** Bug 44201 has been marked as a duplicate of this bug. ***
Comment 47 Brent Fox 2001-07-02 11:04:15 EDT
*** Bug 46877 has been marked as a duplicate of this bug. ***
Comment 48 Brent Fox 2001-07-25 12:08:35 EDT
*** Bug 47969 has been marked as a duplicate of this bug. ***
Comment 49 Brent Fox 2001-10-02 11:58:08 EDT
*** Bug 54234 has been marked as a duplicate of this bug. ***
Comment 50 Jeremy Katz 2002-01-02 15:56:44 EST
*** Bug 57442 has been marked as a duplicate of this bug. ***
Comment 51 Brent Fox 2002-02-06 22:06:31 EST
*** Bug 59373 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.