Bug 209881 - nscd-2.4-11 segfaults
Summary: nscd-2.4-11 segfaults
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 200963 236530
TreeView+ depends on / blocked
 
Reported: 2006-10-07 11:45 UTC by David Eisenstein
Modified: 2008-08-02 23:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 07:22:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nsswitch setup for machine with nscd crashes (353 bytes, text/plain)
2006-10-20 18:23 UTC, Lars Damerow
no flags Details
gdb backtrace for segfaulted nscd. (1.44 KB, text/plain)
2006-10-20 18:24 UTC, Lars Damerow
no flags Details
NSS Conf (1.68 KB, text/plain)
2006-11-08 20:22 UTC, Chris Jones
no flags Details
The output from the short lived nscd (277.07 KB, text/plain)
2007-05-04 16:30 UTC, Chris Jones
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 200963 None None None Never

Description David Eisenstein 2006-10-07 11:45:02 UTC
+++ This bug was initially created as a clone of Bug #200963 +++

From Bug #200963 comment 10:

-- Additional comment from Chris Jones on 2006-10-03 03:55 EST --
This is still a bug in FC5 with the following versions
nscd-2.4-11
glibc-2.4-11

Oct  3 07:23:49 silver kernel: nscd[15245]: segfault at 00002aab40bff13e rip
00002aaaaeb9f025 rsp 0000000040c00100 error 4

Comment 1 David Eisenstein 2006-10-07 11:54:45 UTC
What platform are you running on, Chris?

Comment 2 Chris Jones 2006-10-07 14:36:05 UTC
This was on a x86_64 host.

Comment 3 Jakub Jelinek 2006-10-07 16:08:42 UTC
The above isn't sufficient to determine what the problem is, I certainly can't
reproduce this on any of my FC5 boxes.
So, can you:
1) attach your /etc/nsswitch.conf, so that it is clear what NSS services are in
use
2) install glibc-debuginfo-2.4-11.x86_64.rpm and either run nscd under gdb
and try to reproduce it, or ulimit -c unlimited before you run it and
when it segfaults, get a backtrace where it crashed


Comment 4 Lars Damerow 2006-10-20 18:20:49 UTC
I'm seeing this as well, also on x86_64 hosts using LDAP lookups. I'll attach
our nsswitch.conf and a backtrace. We're currently using nscd-2.4-8, but I'll
install nscd-2.4-11 and see if the problem persists.

Comment 5 Lars Damerow 2006-10-20 18:23:59 UTC
Created attachment 139013 [details]
nsswitch setup for machine with nscd crashes

Comment 6 Lars Damerow 2006-10-20 18:24:52 UTC
Created attachment 139014 [details]
gdb backtrace for segfaulted nscd.

Comment 7 Jakub Jelinek 2006-10-20 20:00:10 UTC
Can you run nscd under
LD_DEBUG=all LD_DEBUG_OUTPUT=/tmp/nscd.debug.out /usr/sbin/nscd
?
Although the backtrace is incomplete, it still shows something that should never
happen in nscd - /usr/sbin/nscd itself exports getaddrinfo symbol and all
libraries calls to getaddrinfo should resolve to the nscd's copy rather than
libc.so.6 (and, libc.so.6's getaddrinfo is the only one containing the
__GI_getaddrinfo alias).

Comment 8 Jakub Jelinek 2006-10-20 20:25:08 UTC
Actually, grepping through nss_ldap and openldap sources, I believe the
#6 backtrace can't be from nscd itself and therefore it is unrelated to this
bugreport.  If nscd itself isn't segfaulting, you are seeing something else.
My guess would be that you have too many nscd lookups and nscd tried
to grow the cache, something that has been fixed recently in FC6 (glibc-2.5-2
and above) and RHEL4 testing glibc.  That will be fixed in FC5 too later,
as a workaround for that (and a proof that it you are actually seeing that bug)
you can edit /etc/nscd.conf, change suggested-size hosts to some larger prime,
like 16381, shut down nscd, rm -f /var/db/nscd/* and start nscd again.

Comment 9 Lars Damerow 2006-10-24 18:09:40 UTC
Thanks, Jakub. My apologies--the core file I was given wasn't from nscd.

I'll try the configuration change you suggested.
-lars

Comment 10 Jakub Jelinek 2006-10-30 08:54:15 UTC
Still waiting on details from the original reporter.  Without them there is
nothing to do here, so if they aren't added soon, I'll close this.

Comment 11 Chris Jones 2006-11-08 20:22:34 UTC
Created attachment 140708 [details]
NSS Conf

Comment 12 Chris Jones 2006-11-08 20:46:03 UTC
Can you be a little more explicit about what you want me to provide (and what I
need to do to get it)?

Comment 13 David Eisenstein 2006-12-24 05:57:10 UTC
*ping*

Comment 14 Chris Jones 2007-04-07 12:54:27 UTC
*pong*

Im still seeing segfaults a couple of times a week from nscd.

Comment 15 David Eisenstein 2007-04-10 01:46:29 UTC
Jakub - in comment #10, you said you are still waiting for details from the
original reporter.  The original reporter should be considered to be Chris 
Jones.

What details do you need from Chris Jones to proceed?  Thanks in advance.

Comment 16 Sitsofe Wheeler 2007-04-11 06:57:17 UTC
This looks like it might be a dup of Bug #190431 ...

Comment 17 Chris Jones 2007-04-11 09:50:58 UTC
Maybe related to  Bug #154314 ? 

Comment 18 Chris Jones 2007-05-04 16:29:22 UTC
Ok, so Bug #236530 seems to be related to this.

I've tried starting nscd with 'LD_DEBUG=all LD_DEBUG_OUTPUT=/tmp/nscd.debug.out
/usr/sbin/nscd' and it stops again. Just doing '/usr/sbin/nscd' works as
expected however. 

Any ideas?

Comment 19 Chris Jones 2007-05-04 16:30:19 UTC
Created attachment 154137 [details]
The output from the short lived nscd

Comment 20 Jakub Jelinek 2007-07-03 07:22:00 UTC
FC5 is no longer supported.  If you can reproduce it with F7 or rawhide, please
reopen.


Note You need to log in before you can comment on or make changes to this bug.