Bug 21002 - Internal compiler error when using -O2 -finstrument-functions
Summary: Internal compiler error when using -O2 -finstrument-functions
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 25091 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-17 10:34 UTC by Alexander Larsson
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 16:26:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed testcase (177.17 KB, text/plain)
2000-11-17 10:35 UTC, Alexander Larsson
no flags Details

Description Alexander Larsson 2000-11-17 10:34:22 UTC
Ok, here is a new -finstrument functions bug. It might be connected to my
previous one 20952, but this one gives an ICE while compiling instead of
generating bad code.

gcc -O2  -finstrument-functions pixops_pre.c 
pixops.c: In function `bilinear_quadrant':
pixops.c:1255: Internal compiler error in change_stack, at reg-stack.c:2214
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

At -O it does not crash.

Comment 1 Alexander Larsson 2000-11-17 10:36:00 UTC
Created attachment 5481 [details]
Preprocessed testcase

Comment 2 Jakub Jelinek 2000-11-21 13:11:41 UTC
Testcase commited to gcc CVS as gcc.dg/20001117-1.c, no fix yet.

Comment 3 Jakub Jelinek 2001-03-14 16:23:05 UTC
I have fixed this in my tree, am just bootstrapping CVS gcc with it before
submitting it to gcc-patches. It will appear later on in gcc-2.96-79.

Comment 4 Jakub Jelinek 2001-03-14 16:26:06 UTC
*** Bug 25091 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.