Bug 25091 - gcc-2.96-71 and -70 internal error (reg-stack.c/change_stack)
Summary: gcc-2.96-71 and -70 internal error (reg-stack.c/change_stack)
Status: CLOSED DUPLICATE of bug 21002
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-27 21:18 UTC by Mike Shaver
Modified: 2007-03-27 03:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-16 17:49:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case: stripped-down version of e_acos.c (913 bytes, text/plain)
2001-01-27 21:19 UTC, Mike Shaver
no flags Details

Description Mike Shaver 2001-01-27 21:18:23 UTC
When compiling fdlibm (from the Mozilla tree) with
  -O2 -finstrument-functions
I get an internal compiler error:

cc -Wall -O2 -finstrument-functions   -c -o e_acos.o e_acos.c
e_acos.c: In function `__ieee754_acos':
e_acos.c:37: Internal compiler error in change_stack, at reg-stack.c:2214

  -O -finstrument-functions
and
  -finstrument-functions
both work fine.

dbaron reports that it happens with -70 as well.

I'll attach a minimized test case.

Comment 1 Mike Shaver 2001-01-27 21:19:06 UTC
Created attachment 8390 [details]
test case: stripped-down version of e_acos.c

Comment 2 Jakub Jelinek 2001-01-27 23:34:17 UTC
This is probably dup of #21002, -finstrument-functions does not play
well with reg-stack and I haven't had time yet to debug this
(I consider it low priority though since -finstrument-functions is
a rarely used switch).

Comment 3 Christopher Blizzard 2001-02-16 17:49:35 UTC
I would get crashes in gcc with that flag in a lot of our C++ test cases, too. 
No profiler for us! :)

Comment 4 Jakub Jelinek 2001-03-14 16:26:12 UTC

*** This bug has been marked as a duplicate of 21002 ***


Note You need to log in before you can comment on or make changes to this bug.