Bug 210127 - Manual Partionning crash
Manual Partionning crash
Status: CLOSED DUPLICATE of bug 208677
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2006-10-10 05:39 EDT by Armel Kermorvant
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-10 09:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Armel Kermorvant 2006-10-10 05:39:57 EDT
Description of problem:
Manually partition creation impossible, system crash

Version-Release number of selected component (if applicable):
Fedora Core6-Pre

How reproducible:

Steps to Reproduce:
1.Remove /swapp
2.Remove /boot
3.Remove LogVol00
4. Remove VolGroup00
5. Remove  /dev/sda1 (LVM PV)
6- Clic New :  The box Appear "An Unhandled exeption has occured. This is
mostlikely a bug, Please repport against anaconda at http://bugzilla.redhat.com"

If I clic on debug, I swoith on text consol and I have : On the screen I have
this infos :
Traceback (most recent call first):
File "/usr/lib/anaconda/iw/partition_dialog_gui_py", line 337, in __init__
File "/usr/lib/anaconda/iw/partition_gui_py", line 1093, in editPartitionRequest
restrictifs =restrictifs)
File "/usr/lib/anaconda/iw/partition_gui_py", line 947, in newCB
self.editPartitionRequest(request, isNew = 1)
TypeError: createAllowedDrivesList() takes exactly 3 arguments (2 given)

Entering debugger...
-> self.originrequest.drive)
Actual results:
Impossible I build by my self my partitions.

Expected results:
Solve issue

Additional info:
Configuration : 
Shuttle F65B
Harddrive : Sata Seagate 160Go (Empty - I remove all partitions on it before the
installation of FC6 - Pre)
Optical : Combo Samsung
Memory : 1.5Go
Video : MX4000 AGP8X

On this system I install FC5, no issue the installation works perfectly
Comment 1 Armel Kermorvant 2006-10-10 05:54:48 EDT
I check on text mode, the partitionning works find :

I continue teh installation

Thanks for your support

Comment 2 Armel Kermorvant 2006-10-10 08:04:36 EDT
Hi again,

I perform the same test on laptop NEC M360 same issue, please find below the
link for this product
Best regards

Comment 3 Chris Lumens 2006-10-10 09:59:50 EDT

*** This bug has been marked as a duplicate of 208677 ***

Note You need to log in before you can comment on or make changes to this bug.