Bug 208677 - anaconda backtraces when I try to create a new volume group
anaconda backtraces when I try to create a new volume group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 208972 209844 210083 210084 210127 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-30 00:29 EDT by Tom Diehl
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 11:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from install (55.75 KB, text/plain)
2006-09-30 00:29 EDT, Tom Diehl
no flags Details
Traceback of Anaconda (53.09 KB, application/octet-stream)
2006-10-01 10:50 EDT, Kwan Lowe
no flags Details

  None (edit)
Description Tom Diehl 2006-09-30 00:29:52 EDT
Description of problem:
Anaconda backtraces when I try to create a volume group

Version-Release number of selected component (if applicable):Rawhide 29 Sep 2006


How reproducible:
Every time

Steps to Reproduce:
1.Start install
2.delete existing volume group
3.click on new and anaconda backtraces.
  
Actual results:
back trace

Expected results:
create new volume group

Additional info:back trace to follow
Comment 1 Tom Diehl 2006-09-30 00:29:52 EDT
Created attachment 137463 [details]
traceback from install
Comment 2 Tom Diehl 2006-09-30 00:31:31 EDT
Changed version to devel since this is rawhide
Comment 3 John Pearson 2006-10-01 10:23:07 EDT
Six tries.  It is enough to select the New button to throw the exception.  You 
do not have to delete anything first.  In one instance, I used fdisk to remove 
all of the partitions from the drive before starting.  Working with fc6 pre and 
trying for a new installation.

Comment 4 John Pearson 2006-10-01 10:40:36 EDT
I don't have a floppy available, but this is the first block of the traceback.
Error transcription:

Traceback (most recent call first):
    File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 337,
in_init_self.origrequest.drive)
    File "/usr/lib/anaconda/iw/partition_gui_.py", line 1093, in
editPartitionRequestrestrictfs = restrictfs)
    File "/usr/lib/anaconda/iw/partition_gui.py", line 947, in
newCBself.editPartitionRequest(request, isNew = 1)
    TypeError: create AllowedDrivesList() takes exactly 3 arguments (2
given)
Comment 5 Kwan Lowe 2006-10-01 10:50:47 EDT
Created attachment 137501 [details]
Traceback of Anaconda

VMWare partition, 8G virtual IDE.
Comment 6 Chris Lumens 2006-10-02 11:36:04 EDT
This will be fixed in the next build of anaconda.
Comment 7 Jeremy Katz 2006-10-02 16:19:43 EDT
*** Bug 208972 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2006-10-06 17:54:04 EDT
*** Bug 209844 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2006-10-09 17:48:20 EDT
*** Bug 210084 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2006-10-09 17:48:26 EDT
*** Bug 210083 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2006-10-10 10:00:02 EDT
*** Bug 210127 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.