Bug 210198 - traceback in getPackage during package installation
Summary: traceback in getPackage during package installation
Status: CLOSED DUPLICATE of bug 209462
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-10 18:56 UTC by Brian Brock
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 19:11:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Brock 2006-10-10 18:56:02 UTC
Anaconda throws an exception with traceback at the beginning of package installation

rawhide-20061010
anaconda-11.1.0.110-1

occurs on at least x86_64, awaiting i386 results.
seems to recur on all hardware reliably


<Oct/10 01:14 pm>Starting install process.  This may take several minutes...
<Oct/10 01:14 pm>Preparing transaction from installation source...
<Oct/10 01:14 pm>In progress...    
<Oct/10 01:14 pm>Installing libgcc-4.1.1-28...  Traceback (most recent call first):
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/yuminstall.py", line 198, in getPackage
<Oct/10 01:14 pm>    return self.__get(relative=remote,
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/yuminstall.py", line 136, in callback
<Oct/10 01:14 pm>    fn = repo.getPackage(po)
<Oct/10 01:14 pm>  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line
454, in runTransaction
<Oct/10 01:14 pm>    errors = self.ts.run(cb.callback, '')
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/yuminstall.py", line 477, in _run
<Oct/10 01:14 pm>    self.runTransaction(cb=cb)
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/yuminstall.py", line 452, in run
<Oct/10 01:14 pm>    self._run(instLog, cb, intf)
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/yuminstall.py", line 1194, in doInstall
<Oct/10 01:14 pm>    self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/backend.py", line 163, in doInstall
<Oct/10 01:14 pm>    anaconda.backend.doInstall(anaconda)
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
<Oct/10 01:14 pm>    rc = stepFunc(self.anaconda)
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
<Oct/10 01:14 pm>    self.moveStep()
<Oct/10 01:14 pm>  File "/usr/lib/anaconda/cmdline.py", line 130, in run
<Oct/10 01:14 pm>    anaconda.dispatch.gotoNext()
<Oct/10 01:14 pm>  File "/usr/bin/anaconda", line 956, in ?
<Oct/10 01:14 pm>    anaconda.intf.run(anaconda)
<Oct/10 01:14 pm>AttributeError: 'AnacondaYumRepo' object has no attribute
'_AnacondaYumRepo__get'

<Oct/10 01:14 pm>install exited abnormally [1/1]

Comment 1 Brian Brock 2006-10-10 18:59:47 UTC
Those results may actually have come from 

FC6-re20061010.0

double-checking results in both trees.

Comment 2 Chris Lumens 2006-10-10 19:11:46 UTC

*** This bug has been marked as a duplicate of 209462 ***


Note You need to log in before you can comment on or make changes to this bug.