Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 210260 - install fails immediately at start of package installation
install fails immediately at start of package installation
Status: CLOSED DUPLICATE of bug 209462
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-10-10 22:08 EDT by David Miller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 10:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failure debugging log from installer (187.56 KB, text/plain)
2006-10-10 22:08 EDT, David Miller
no flags Details

  None (edit)
Description David Miller 2006-10-10 22:08:36 EDT
Description of problem:

Install fails at the installation of the first package.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1.download boot.iso from devel, boot
2.select packages, customize by adding "software development", "chinese",
"japanese", and "korean" to installation set
3.begin installation
  
Actual results:

Install fails at first package install.

Expected results:

Install succeeds.

Additional info:

Will attach debugging log provided by the installer.
Comment 1 David Miller 2006-10-10 22:08:37 EDT
Created attachment 138211 [details]
failure debugging log from installer
Comment 2 David Miller 2006-10-10 23:49:51 EDT
test4 i386 DVD fails in a similar fashion, I double checked that the
DVD image was burned correctly:

1) boot into graphical installer
2) select "software development" package group, this issues a prompt indicating
that a network interface is necessary for that selection, say "OK"
3) it tries to bring the network interface up
4) anaconda error triggers

I had to write the following debug backtrace by hand since the installer
didn't give me an option of "scp'ing" the debug log as the boot.iso
case did, but here goes:

Traceback (most recent call first):
 File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 212, in _ok
   if self.rc != gtk.RESPONSE_OK:
AttributeError: 'module' object has no attribute 'RESPONSE_OK'

Local variables in innermost frame:
val: eth0
f: <closed file '/etc/resolv.conf', mode 'w' at 0xa2ffd10>
netdev: DEVICE=eth0
BOOTPROTO=static
HWADDR=00:11:25:D2:42:89
ONBOOT=no

self: <network_dialog.NetworkConfigurator instance at 0xb7b668cc>
args: (<gtk.Button object (GtkButton) at 0xa2e86e4>,)
w: <gui.WaitWIndow instance at 0xa3faeac>
combo: <gtk.ComboBox object (GtkComboBox) at 0xa2e870c>
active: <GtkTreeIter at 0x9f86da0>
ns: 64.81.79.2
Comment 3 David Miller 2006-10-10 23:53:33 EDT
Backtrace from Pdb of the test4 DVD failure case:

(Pdb) bt
  /usr/bin/anaconda(954)?()
-> anaconda.intf.run(anaconda)
  /usr/lib/anaconda/gui.py(876)run()
-> self.icw.run (self.runres)
  /usr/lib/anaconda/gui.py(1112)run()
-> gtk.main()
  /usr/lib/anaconda/iw/task_gui.py(169)_toggled()
-> ret = net.run()
  /usr/lib/anaconda/iw/netconfig_dialog.py(128)run()
-> gtk.main()
> /usr/lib/anaconda/iw/netconfig_dialog.py(212)_ok()
-> if self.rc != gtk.RESPONSE_OK:
(Pdb)
Comment 4 Jeremy Katz 2006-10-11 10:36:38 EDT
For the second, please read the announcement for Fc6Pre which had the link to an
updates.img with the fix as well as how to use it.  The first is also a dupe 

*** This bug has been marked as a duplicate of 209462 ***

Note You need to log in before you can comment on or make changes to this bug.