Bug 210264 - anaconda crash in yuminstall.py
anaconda crash in yuminstall.py
Status: CLOSED DUPLICATE of bug 209462
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 23:42 EDT by Mark Smith
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 10:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback dump offered for remote copy when anaconda crashed (238.79 KB, text/plain)
2006-10-10 23:42 EDT, Mark Smith
no flags Details

  None (edit)
Description Mark Smith 2006-10-10 23:42:21 EDT
Description of problem:
anaconda crash during install (disks already formatted, install underway)

Version-Release number of selected component (if applicable):
Oct10 snapshot of rawhide. Not seen on same lpar with Oct6 snapshot of rahide.

How reproducible: easy


Steps to Reproduce:
1. netboot ppc64 system with rawhide ppc64.img (Oct 10 version)
text (or vnc) install mode; both recreate
power5 system has Veth for eth0, Vscsi client disks: sda, sdb
configure eth0 as static and point to nfs://rhlte/distros/rawhide_snap/ dir
2. anaconda will start. accept default partitioning offered (doesn't seem to
matter).
3. when eth0 config menu is offered, accept defaults offered (is same as when i
config'd it to start the nfs install):
4. accept default packages offered (office productivity). Add "development" if 
you want; it doesn't matter.
5. start install.  disks format.  RPM transactions start. anaconda crashes.
  
Actual results:
cannot install

Expected results:
successful install

Additional info:
I will attach the traceback
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 198, in getPackage
    return self.__get(relative=remote,
  File "/usr/lib/anaconda/yuminstall.py", line 136, in callback
    fn = repo.getPackage(po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 454, in 
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py", line 477, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/anaconda/yuminstall.py", line 452, in run
    self._run(instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 1194, in doInstall
    self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 163, in doInstall
    anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 540, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 956, in ?
    anaconda.intf.run(anaconda)
AttributeError: 'AnacondaYumRepo' object has no 
attribute '_AnacondaYumRepo__get'
Comment 1 Mark Smith 2006-10-10 23:42:21 EDT
Created attachment 138216 [details]
traceback dump offered for remote copy when anaconda crashed
Comment 2 Chris Lumens 2006-10-11 10:21:19 EDT

*** This bug has been marked as a duplicate of 209462 ***

Note You need to log in before you can comment on or make changes to this bug.