This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 210269 - 5 usability improvements of SCIM Pinyin Helper.
5 usability improvements of SCIM Pinyin Helper.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: scim-pinyin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
: i18n
: 207259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 02:08 EDT by Caius Chance
Modified: 2008-03-04 00:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 00:20:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2006-10-11 02:08:14 EDT
Description of problem:
There are 5 usability improvements are required to be in SCIM Pinyin Helper.

Version-Release number of selected component (if applicable):
scim-pinyin-0.5.91-13


How reproducible:
Always.

Pre-Steps to Reproduce:
1. Go to "SCIM Setup" window.
2. Click on "Smart Pinyin".
3. Click on "Input" tab.
4. Check "Show pinyin helper property in the tool bar".
5. Click on "OK" button.

Steps to Reproduce (Improvement 1) & Actual results:
1. Open CLI on Gnome.
2. Type GTK_IM_MODULE=scim gedit.
3. With gedit window focused, switch on SCIM and select Smart Pinyin.
4. Click on ”词“ on the toolbar, helper window will pop up.
5. Quit gedit, helper window is still there with no reponses to events.

Steps to Reproduce (Improvement 2) & Actual results:
* Redo Step 1-4 in Improvement 1.
5. Click on "Add" button.
6. Switch on SCIM, input method is reverted to English/European.

Steps to Reproduce (Improvement 3) & Actual results:
* Redo Step 1-6 in Improvement 2.
7. Input Chinese phrase on first input field by any input method and press enter
key.
8. Switch on SCIM at the second input field, input method is reverted to
English/European.

Steps to Reproduce (Improvement 4) & Actual results:
* Redo Step 1-7 in Improvement 3.
8. Click "Submit", the window doesn't show the status (list/adding process) of
helper.

Steps to Reproduce (Improvement 5) & Actual results:
* Redo Step 1-4 in Improvement 1.
5. Click on any window of other program, helper window was covered by others.

Expected results:
Improvement 1: helper window should be closed.
Improvement 2 & 3: previous input method should be restored.
Improvement 4: current status should be shown on helper window.
Improvement 5: helper window should be always on top.

Additional info:
Please finish bug #200702 before solving this bug.
Comment 1 Caius Chance 2006-10-16 03:41:21 EDT
*** Bug 207259 has been marked as a duplicate of this bug. ***
Comment 2 Peng Huang 2008-03-04 00:20:29 EST
The scim-pinyin-helper has been dropped from rawhide. So I will mark it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.