This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 21044 - netscape-4.76 conflicts with helix gnome-core
Summary: netscape-4.76 conflicts with helix gnome-core
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 21180 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-18 07:20 UTC by Felix Lee
Modified: 2013-04-02 04:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-21 15:52:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felix Lee 2000-11-18 07:20:27 UTC
netscape-4.76 rpm now includes /usr/share/pixmaps/netscape.png , which is
also in the gnome-core rpm.  this is fine for redhat-only installations,
because it's an identical file.

however, helix gnome supplies different pixmaps, so if you have helix
installed, netscape-4.76 fails to install cleanly.  (or vice-versa)

I don't see a good fix for this problem that doesn't involve changing rpm. 
perhaps marking netscape.png as %config(noreplace) is good enough, but this
seems to be stretching the idea of a config file a bit.  (it might need to
be applied to everything in /usr/share/pixmaps .)

Comment 1 Bill Nottingham 2000-11-19 05:49:12 UTC
netscape.png, ideally, shouldn't be in gnome-core.

Alternatively, if a package contains 'Icon: something' in its desktop
entry, do we really want to make the package require whatever provides
that icon (because making netscape require gnome-core would be silly.)



Comment 2 Bill Nottingham 2000-11-21 15:52:01 UTC
*** Bug 21180 has been marked as a duplicate of this bug. ***

Comment 3 Elliot Lee 2001-02-02 21:17:22 UTC
Fixed in gnome-core-1.2.4-5


Note You need to log in before you can comment on or make changes to this bug.