Bug 210442 - rectangles instead of letters after pango update
rectangles instead of letters after pango update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 02:42 EDT by J.Jansen
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: pango-1.12.4-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 21:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copy of "/etc/pango/i686-redhat-linux-gnu/pango.modules" (2.38 KB, application/octet-stream)
2006-10-12 17:56 EDT, Kevin Verma
no flags Details

  None (edit)
Description J.Jansen 2006-10-12 02:42:34 EDT
Description of problem:
After installation of todays( 12 October) update of pango, all letters on my
gnome desktop are replaced by rectangles. Additionally firefox will not start at
all.Mozzilla gives in some menus also rectangles. Probably some more gtk2
applications suffer from this problem

Version-Release number of selected component (if applicable):
last update of pango for FC5

How reproducible:



Steps to Reproduce:
1.install pango update
2.reboot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 J.Jansen 2006-10-12 03:20:47 EDT
I downgraded pango to the previous update and the problem is gone
Comment 2 J.Jansen 2006-10-12 03:21:55 EDT
Reinstalling the update gives the same problem again. So something is wrong with
the update
Comment 3 Behdad Esfahbod 2006-10-12 17:22:43 EDT
Very weird.  What are the contents of
/etc/pango/i386-redhat-linux-gnu/pango.modules before and after the update?

Is it a x86_64 machine by any chance?
Comment 4 Kevin Verma 2006-10-12 17:56:23 EDT
Created attachment 138387 [details]
copy of "/etc/pango/i686-redhat-linux-gnu/pango.modules"
Comment 5 Kevin Verma 2006-10-12 18:00:00 EDT
I am facing the closely simillar issue after this update, I have not yet
rebooted but I see fonts as rectangles for NetworkManager and Tomboy, Firefox is
so far working, 

but as I have made an attachment of the file
"/etc/pango/i686-redhat-linux-gnu/pango.modules" from the recent update, I am
now downgrading. 
Comment 6 Michael Hurley 2006-10-12 20:39:49 EDT
FWIW, I fixed this problem on my system by chmodding
/etc/pango/i686-redhat-linux-gnu/pango.modules to 0644.
Comment 7 Behdad Esfahbod 2006-10-12 20:55:01 EDT
Ah, that gives some insight.

Those experiencing the bug, do you have a strict umask set for your root user?
Comment 8 Behdad Esfahbod 2006-10-12 20:55:45 EDT
This is prolly a FC5 dupe of bug 185419.
Comment 9 Kevin Verma 2006-10-12 21:30:06 EDT
[04:09:59 localhost:~]# umask
0022
[06:54:27 localhost:~]# touch test-file
[06:55:13 localhost:~]# ls -l test-file
-rw-r--r-- 1 root root 0 Oct 13 06:55 test-file

( seems not )
Comment 10 Michael Hurley 2006-10-12 22:03:44 EDT
Same for me as Kevin reports: root's umask is 0022. However, the pango.modules
file was set to 0600 after the pango update. 

To troubleshoot, I logged into X as root, and the fonts appeared, not the
rectangles (this makes sense now, since root could read pango.modules). I
narrowed down the problem by logging into X as a non-privileged user and running
 "metacity --replace" from an xterminal, and seeing what errors popped up. That
led me to su to root, save the pango.modules as pango.modules.old, and run
"pango-modules-32 > pango.modules". diff showed that the old and new files were
identical, so it had to be the permissions. The old file was 0600, new file was
0644. Logged out and back in, et voila, the fonts are back. 
Comment 11 Behdad Esfahbod 2006-10-12 22:45:16 EDT
Humm, how did you get the rpm installed?  yum?
Going to push the fix soon, but I really want to know what caused the wrong
umask in the first place.
Comment 12 Michael Hurley 2006-10-12 22:52:51 EDT
Yes, YUM.  I used "Software Updater."
Comment 13 J.Jansen 2006-10-13 01:53:22 EDT
I used yumex to install. 
The umask of root is 022
My own umask is 77.
I'm not sure which umask yumex is taking since I'm running it from my own
account. The first thing it does is ask for the root-password and than it runs
in priviledged mode.

                 Jouk
Comment 14 J.Jansen 2006-10-13 02:06:43 EDT
chmodding /etc/pango/i686-redhat-linux-gnu/pango.modules to 0644 works also at
my system. After installation only the owner root had "rw" rights.

            Jouk
Comment 15 Alfredo Ferrari 2006-10-13 05:26:50 EDT
Same issue here. This is a x86_64 installation with both pango x86_64 and i386
installed (the latter for various 32 bit apps).

The funny thing is that /etc/pango/x86_64-redhat-linux-gnu/pango.modules got
the right permissions, while /etc/pango/i686-redhat-linux-gnu/pango.modules got
them wrong. My root umask is 022, I upgraded using pup. But even when upgrading
by hand (ie rpm -Fvh pango-1.2.4-3.i386.rpm, after having downgraded to the
previous version) I get the wrong permissions. I have two other machines (both
i386) where the upgrade was flawless.
Comment 16 Behdad Esfahbod 2006-10-13 11:08:51 EDT
I'm pushing another update that fixes this issue.  If you run yumex under your
account and it asks for the root password, most probably it inherits the 077
umask from your user account.
Comment 17 Robert E Laughlin 2006-10-14 10:40:10 EDT
This same update broke VMwareWorkstation.  I get an error complaining about
permission denied opening /usr/lib/vmware/libconf/etc/pango/pangorc.  The mode
is 600.  Chmoding to 644 and VMwareWorkstation starts, then dies and restarts
working correctly.  I can't find any more error messages. So I can't point to
something else that is broken.
Comment 18 Behdad Esfahbod 2006-10-14 12:21:14 EDT
(In reply to comment #17)
> This same update broke VMwareWorkstation.  I get an error complaining about
> permission denied opening /usr/lib/vmware/libconf/etc/pango/pangorc.  The mode
> is 600.  Chmoding to 644 and VMwareWorkstation starts, then dies and restarts
> working correctly.  I can't find any more error messages. So I can't point to
> something else that is broken.

I don't understand.  Pango doesn't install
/usr/lib/vmware/libconf/etc/pango/pangorc.
Comment 19 Robert E Laughlin 2006-10-14 19:34:59 EDT
Ok, maybe this is a file that is created when VMwareWorkstation is installed. 
Every thing is usable now, I will wait until the next update of pango, then
delete VMwareWorkstation and see what happens.  By the way I just noticed that
now Thunderbird has a not of its opening page that moz_diable_pango = 1.  That
was never there before.
Comment 20 Fedora Update System 2006-10-16 10:57:30 EDT
pango-1.12.4-4 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.