This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 210597 - Installer hangs on G965 chipset after ACPI
Installer hangs on G965 chipset after ACPI
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
bzcl34nup
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2006-10-12 22:54 EDT by Daniel Davies
Modified: 2015-01-04 17:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg log file for the machine in last comment (19.95 KB, text/plain)
2006-10-20 23:43 EDT, Dario Andrade
no flags Details

  None (edit)
Description Daniel Davies 2006-10-12 22:54:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
The Fedora Core 5 installer hangs after printing out a bit over a screen's worth of data.  See detailed description in "Additional Information".

Version-Release number of selected component (if applicable):
Fedora Core 5

How reproducible:
Always


Steps to Reproduce:
1.Set BIOS to boot from CD/DVD drive
2.Insert either Fedora Core 5 DVD, Fedora Core 5 CD 1
3.Reset PC
4. Type [Enter] (or askmethod or mediacheck or pretty much anything else) at splashs screen prompt

Actual Results:
Installer hangs as described below

Expected Results:
Installer should have installed Fedora Core 5

Additional info:
System: Intel DG965RY motherboard
Chipset G965
Sony DRU-720A CD/DVD
Seagate ST380013AS Barracuda 7200 SATA disk
E6700 Core 2 Duo
2 GB of DDR2 800 MHz SDRAM
No add in cards

Installer hangs after printing out the following lines

.
.
.
Intel(R) Core(TM)2 CPU    6700  @ 2.66 GHz stepping 06
Brought up 2 CPUs
testing NMI watchdog ... OK
migration_cost=15
checking if image is initramfs... i is
Freeing initrd memory: 5998k freed
NET: Registered protocol family 16
ACPI: bus time pci registerd
PCI: Using MMCONFIG at f0000000
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
ACPI: Assume root bridge [\?SP_.PCI0] bus is 0
Comment 1 Dave Jones 2006-10-16 20:26:55 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 2 Daniel Davies 2006-10-16 20:43:36 EDT
I'd be delighted to test Kernel 2.6.18-1.2200.fc5, but I don't have any idea how
to do so.  I don't have a machine that runs any flavor of Linux since I can't
install Fedora on this one.  I also don't know how to grab a new version of the
kernel or what to do with it if I had it.

SORRY!!
Comment 3 Jarod Wilson 2006-10-16 20:52:22 EDT
The Fedora Unity project does respins of older releases with updated kernels etc
(http://fedoraunity.org/), which may be a starting point.

You might also want to give FC6 a try, to see if that works.  Its likely just
a case of the kernel on the original FC5 media not being new enough.
Comment 4 Dave Jones 2006-10-16 20:56:06 EDT
ahh, I think this one can be worked around by booting the install CD with

linux pci=nommcfg

can you give that a try ?
Comment 5 Daniel Davies 2006-10-16 21:22:33 EDT
Killing two birds with one stone, I tried FC6, Test 3 with

linux pci=nommcfg

I hung in the same place.  Next, I tried

linux acpi=off

This got further, eventually reaching a window that says

-----------------------------------------------
            No driver found

Unable to find any devices of the type
needed for this installation type.
Would you lik to manually select your
driver or use a driver disk?
-----------------------------------------------

I attempted to select a driver from the list of disk drivers, but didn't see
anything that looked like a driver for the IDE controller embedded inside the
G965 chipset.
Comment 6 Daniel Davies 2006-10-16 21:24:24 EDT
It doesn't look like FedoraUnity has a respin with the latest kernel that Dave
Jones referenced.
Comment 7 Dave Jones 2006-10-16 21:38:47 EDT
ah, I misremembered the option
it's actually..

linux pci=nommconf
Comment 8 Daniel Davies 2006-10-16 21:49:14 EDT
linux pci=nommconf

gets me to the same place as specifying

linux acpi=off

It still says it can't find the right driver.  I assume it's looking for an IDE
driver that will work on the Intel chipset.
Comment 9 Dave Jones 2006-10-16 21:57:21 EDT
Hmm, I'm out of ideas for now.
Adding the Intel ACPI folks to the Cc, maybe they have ideas.
Comment 10 Daniel Davies 2006-10-17 14:35:32 EDT
Stumbling around on Intel's web site last night, I found
http://www.intel.com/cd/channel/reseller/asmo-na/eng/products/linux/feature/319373.htm.
 It looks like Intel provides drivers for this board on a bunch of Linux
distributions, but not Fedora Core, SUSE Linux 10.1 or the other free distributions.
Comment 11 Dario Andrade 2006-10-20 23:41:59 EDT
I've got a
custom 2.6.18 compiled kernel
GD965SS intel motherboard
SATA harddrive
4gb 533 ddr2 kingston
core 2 duo E6300

I have the same problem as Daniel.

I had to compile the new 2.6.18 kernel because the embedded Intel PRO 
10/100/1000 that ships with the motherboard does not have a driver with <2.6.18 
kernels.

I've managed to install it using linux acpi=off, and now I found out that only 
one of the processors is active.

I am about to test the new 2.6.18-1.2200 FC5 kernel, but I don't expect too 
much from it.

I've read in some forums that disabling legacy usb (usb keyboard) in BIOS might 
work. I'll have to give it a try later this month, since tha machine is in 
production right now.

Comment 12 Dario Andrade 2006-10-20 23:43:56 EDT
Created attachment 139045 [details]
dmesg log file for the machine in last comment

This is the dmesg log after booting custom compiled 2.6.18 kernel using
acpi=off.
Comment 13 Radhakrishnan 2007-12-11 05:41:46 EST
I've got a 
INTEL core 2 quad Q6600 2.4Ghz
GD965RY motherboard
160 GB sata HDD
4GB 800 ddr2 Transcend

FC7 64bit works fine with 3GB ram but very very slow [not usable]with 4GB ram.

my 1GB RAM is kept out.

all my devices r properly configured.
no error .

Thanks
Comment 14 Bug Zapper 2008-04-03 23:57:35 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 15 Bug Zapper 2008-05-06 12:27:52 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.