Bug 210617 - No IPv6 support (with patch)
No IPv6 support (with patch)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
Depends On:
Blocks: IPv6Blocker 218422
  Show dependency treegraph
 
Reported: 2006-10-13 07:14 EDT by Tim Waugh
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 03:50:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc-ipv6.patch (2.09 KB, patch)
2006-10-13 07:14 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2006-10-13 07:14:36 EDT
Description of problem:
With /etc/hosts like this:

==>
::1    localhost.localdomain    localhost
<==

(as shipped by default in FC6) try this command: vncviewer :1

It fails.

Version-Release number of selected component (if applicable):
4.1.2-3.fc6

How reproducible:
100%

Steps to Reproduce:
1. vncviewer :1
  
Actual results:
unable to resolve host by name: Success (0)

Expected results:
Connection refused.

Additional info:
Patch attached.
Comment 1 Tim Waugh 2006-10-13 07:14:36 EDT
Created attachment 138416 [details]
vnc-ipv6.patch
Comment 2 Adam Tkac 2006-10-13 07:17:16 EDT
thank you for patch
Comment 3 Fedora Update System 2006-10-20 15:26:12 EDT
vnc-4.1.2-4.fc7 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Tim Waugh 2006-10-23 12:48:18 EDT
The problem is more apparent in FC6 really.
Comment 5 Adam Tkac 2006-10-24 03:50:16 EDT
(In reply to comment #4)
> The problem is more apparent in FC6 really.

oops, my mistake. vnc-4.1.2-4.fc6 has been pushed for fc6 now. update will be
avaliable in future 2 days

Note You need to log in before you can comment on or make changes to this bug.